0

I'm having this characters '>' when I'm tabbing using VIM. how can I remove this when tabbing? It's very annoying

Screenshot

  • 2
    list is disabled by default and the default value of listchars doesn't contain ▶︎. This means that you enabled list and you defined listchars. So… why ask? Just revert your own settings. – romainl Nov 3 '16 at 6:30
3

This is because of the listchars option. The idea is that you can display certain whitespace characters (tab, space, newline, etc.) as a different character so you can see them better. I'm guessing if you type:

:set listchars?

you will see something like

listchars=tab:(that arrow)

as well as some other settings. To disable this, you can change what tabs are displayed as, for example:

:set listchars+=tab:\ \ 

(note the trailing space)

or you may simply turn this off entirely by running

:set nolist

Recommended reading: :h 'list' and :h listchars

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.