0

It's a couple of month that I'm using Vim and I'm happy with it. But working on big files (About 2000 lines) is really annoying.
I have some plugins and today I wanted to fix this problem. So I removed them and tested again, But oddly performance was the same!
So I removed .vimrc from $HOME and saw it works fine (I had syntax:on, So not too fine). Tested again with vim -u NONE and it was great.
But when I created an empty .vimrc in $HOME and the slowing down problem came back!
Currently I'm using Fedora 27 with Vim 8.0.1427.
I did some research but didn't find anything related to this problem. So if there is something I could do to fix this, I appreciate your help.

  • 2
    You should have a look at this question in the current state of your question we can't do a lot to help you. – statox Jan 8 '18 at 12:32
  • 1
    one thing you can also try is rm ~/.viminfo. It sometimes happens that this file is very big and full of information you do not need, which may slow down starting vim. – Naumann Jan 8 '18 at 13:59
  • @Naumann Did that before, Nothing changes unfortunately. – Shantia Jan 9 '18 at 8:44
  • @mMontu I didn't know about that! There was 2 lines of commands in help that said we should add it to our custom .vimrc, And that fixed it, Thank you! If you could add your comment as a post, So I could mark it as answer. – Shantia Jan 9 '18 at 8:46
  • Glad the issue is gone – mMontu Jan 9 '18 at 11:55
1

Note that in version 8 Vim started loading some default configuration when no vimrc is found - :help defaults.vim. So you could try loading those defaults in your vimrc (as explained on that help entry), and if it solves the problem you can comment it until you find the setting that you are missing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.