0

I just installed tmux, iTerm2 and Vim. However, when i open Vim i have this bar with arrows on the left side. I don't know if it's there because of Vim or the terminal emulator. Is there a way to remove it?

enter image description here

12
  • The numbers are there because you enabled set number in your vimrc file. The >> are called signs, and are probably added by some plugin such as Syntastic which you added to your vimrc file. See: How do I debug my vimrc file? Aug 20 '15 at 12:13
  • @Carpetsmoker I also suspected this happened because of some plugin , I have 27 plugins installed right now , is there a way i can just disable it directly instead of debugging the .vimrc file ?
    – MicroGame
    Aug 20 '15 at 12:43
  • 1
    Just comment them out one-by-one and see when the problem stops appearing? Aug 20 '15 at 13:03
  • 2
    ... Yes, this will take more time, but you will actually understand what you're doing, rather than fumbling around cluelessly :-) Aug 20 '15 at 13:56
  • 3
    So… you just installed Vim and you already have 27 plugins?
    – romainl
    Aug 20 '15 at 16:01
2

I see you have found the culprit plugin already, but here's how you could go hunting for it if it happens again.

Before the pathogen#infect() line in your vimrc, first add let g:pathogen_disabled = [] and then for each plugin add a line like call add(g:pathogen_disabled, {plugin-name}). Then remove them or comment them out one by one until the undesirable behavior reappears.

The plugin name corresponds to the folder name in your pathogen bundle folder. To quickly add all the plugins to the disabled list you can do, with your cursor on the line above pathogen#infect()

:read !ls ~/.vim/bundle

This gives you the names of all the plugins that pathogen loads. If your plugins are not in .vim/bundle then adjust the path.

Then do

V'[

to select the lines you just added. Then

:s/.*/call add(g:pathogen_disabled, '\0')

to change each line into a call to add the plugin to the disabled list.

Finally, to answer your actual question, if you have signs and you want to remove them, you can do (see :help signs).

:sign unplace *

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.