2

From iskeyword's doc I read that its default on Linux is @,48-57,_,192-255.

However, when I open a *.tex file, echo &iskeyword gives @,48-57,_,192-255,:.

Where in the startup of Vim is that : appended to the default for TeX files?

And is there a rational as to why? I've just found annoying what happened when I pressed * while with the cursor on a word in prose immediately followed by :.

5
  • 1
    Check :verbose set isk? Dec 15, 2022 at 16:41
  • @ChristianBrabandt, I'd say that's the answer.
    – Enlico
    Dec 15, 2022 at 17:02
  • I don't have the same behavior. Have your tried with a bare version of Vim? Dec 15, 2022 at 17:15
  • 2
    @VivianDeSmedt, indeed, the command Crhistian Brabandt suggested showed that vimtex is changing the option.
    – Enlico
    Dec 15, 2022 at 17:21
  • 2
    I believe this is for supporting LaTeX's expl3 syntax, but I feel it's more annoying than useful most of the time.
    – user202729
    Dec 16, 2022 at 9:31

1 Answer 1

2

You can check what plugin or script is changing the value by using the following command:

:verbose set isk?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.