1

I've remapped q to :bp, but to get an instant response, I have to press it twice. Otherwise there's a two second delay. What could be causing this and how can I fix it?

function! NetrwMapping()
  noremap <buffer> q :bp<CR>
endfunction
  • I tried :nmap q :bp<CR> and that worked without a delay for me. Although if you've mapped something else to q<some other key>, that might be causing the delay. You can check this by trying :nmap q and see what the output is. – Tumbler41 Sep 10 '16 at 5:26
  • 1
    Please provide the exact command you used to remap it, otherwise, nobody can help you. – James Sep 10 '16 at 7:01
4

This happens because Vim waits to see if you want to do q<letter> to start recording a macro (there are a couple other things too like q:). You can use the tm option to change the amount it waits(will apply to all maps), or remap it to another unused letter.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.