0

I run Neovim v0.9.1 using Lua 5.1 (not LuaJIT) and telescope. As soon as I invoke telescope.builtin.git_files, Neovim shows the following error:

E5108: Error executing lua: ...ugins/telescope.nvim/lua/telescope/builtin/__git.lua:431: attempt to call field 'tbl_isarray' (a nil value)
stack traceback:
        ...ugins/telescope.nvim/lua/telescope/builtin/__git.lua:431: in function 'try_worktrees'
        ...ugins/telescope.nvim/lua/telescope/builtin/__git.lua:477: in function 'set_opts_cwd'
        ...ugins/telescope.nvim/lua/telescope/builtin/__git.lua:493: in function <...ugins/telescope.nvim/lua/telescope/builtin/__git.lua:490>
        (tail call): ?
        ...lugins/telescope.nvim/lua/telescope/builtin/init.lua:580: in function <...lugins/telescope.nvim/lua/telescope/builtin/init.lua:539>

I tried invoking :lua vim.tbl_isarray() which gives the same error. Neovim's documentation lists vim.tbl_isarray(), so I am surprised it is not found.

What am I missing?

1
  • Rather than check the online docs, try your local :help. It's possible you need a newer version of NeoVim.
    – D. Ben Knoble
    Aug 8, 2023 at 19:48

1 Answer 1

0

Had the same issue today when I updated my whole Neovim. I rolled Telescope back to version 0.1.2, commit 776b509 https://github.com/nvim-telescope/telescope.nvim/releases/tag/0.1.2

and seems to work again. I am running on Neovim 0.9.1

On Packer this was something like:

use {
  'nvim-telescope/telescope.nvim', 
   commit = '776b509',
   requires = { {'nvim-lua/plenary.nvim'} }
}

-- OR

use {
  'nvim-telescope/telescope.nvim', 
   tag = '0.1.2',
   requires = { {'nvim-lua/plenary.nvim'} }
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.