:help undercurl states:

"undercurl" is a curly underline. When "undercurl" is not possible then "underline" is used. In general "undercurl" and "strikethrough" is only available in the GUI.

But if I run Vim with vim --clean and then issue the following commands, then the text curl is not highlighted in any way:

:hi Curl cterm=undercurl
:match Curl /curl/

However, if I change undercurl to underline, then curl is now underlined:

:hi Curl cterm=underline

Is the documentation wrong? Or am I just misinterpreting it?*

Or is the problem that Vim thinks that undercurl is possible and is therefore (unsuccessfully) attempting to use it? If this is the case, then what causes this? :set t_Cs? and :set t_Ce? both report that the settings are not set:


I'm running Vim 8.0.1420 inside iTerm2 v3.2.6 on macOS.

* It could be read to mean that there are some circumstances when undercurl is available but isn't possible and only in those cases will it be replaced with an underline.

1 Answer 1


Looks like this is just a bug, which was fixed just after the version I'm using, in patch 8.0.1422.

  • here I am, in the distant future, still having this same problem with vim 9.1.80. Under both konsole and xterm.
    – gcb
    Mar 5 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.