0

Some of the times I use YouCompleteMe, Vim 'half-crashes': I cannot continue coding in the current tab, but switching tab and coming back solves the issue.

The autocompletion works about 80% of the time, 20% of the time it crashes. It happens in two different computers, although both are running Ubuntu 16.04 with the same bashrc and same vimrc.

Just before pressing tab to autocomplete it looks like this:

Just before

Just after pressing tab it looks like this:

Just after

I think the mention of /bin/bash and unexpected EOF are pretty consistent every time it crashes. It also doesn't explicitly mention YCM so I'm not entirely sure that's the issue. It's also likely I have a problem in my vimrc but it's not mentioned in the error message either.

Any ideas on what to look for?

Thanks!

  • 2
    The first thing you should look for is the plugin's issue tracker the author and the plugin community should be able to tell you what's going on or to fix the bug if it is one. – statox Oct 9 '17 at 14:12
  • Yup; I looked there before asking here, but couldn't find anything + wasn't entirely sure it was about youcompleteme. Thanks for the suggestion, though. – etal Oct 9 '17 at 19:01
  • If Tuyen Phams suggestion doesn't work open up an issue on the YCM repo. As long as you go through their process of pre-issue checks and debugging etc it'll be fine. If its a YCM issue they'll try solve it and if it isn't someone may have seen it before and will be able to advise how to fix it – ljden Oct 11 '17 at 1:24
  • I tried installing YCM in another vimrc and it worked, so I'm pretty sure it's not a YCM issue. Looking at your links I found there's a group to discuss issues, which may be more appropriate. Thanks! – etal Oct 12 '17 at 14:00
1

Common issue is that you don't re-compile YCM when you upgrade it. Try

cd ~/.vim/bundle/YouCompleteMe
./install.py

refer here.

  • Doing this I noticed there were a couple things failing/missing, which I was able to solve. Unfortunately this didn't solve the original issue. Thanks though :) – etal Oct 12 '17 at 13:58
  • If possible, I'd suggest you post your vimrc, so we can reproduce the errors. – Tuyen Pham Oct 12 '17 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.