I was reading vimtutor and in lesson 2.1 there was this note about typing commands like dw:

NOTE: The letter  d  will appear on the last line of the screen as you type
    it.  Vim is waiting for you to type  w .  If you see another character
    than  d  you typed something wrong; press  <ESC>  and start over.

but I can't see the commands that I am typing in command line neither in vim or gvim. How can I fix that?


3 Answers 3


Add this line into you .vimrc , either source it or restart vim.

set showcmd

And yes If you are experimenting with your vimrc and tired of sourcing it after every change, add this line.

autocmd BufWritePost .vimrc source %
  • 1
    @allsysed : Can you explain what the below command does
    – aspiring1
    Dec 24, 2019 at 9:01
  • @aspiring1 autocmd means to automatically execute an action. BufWritePost is a condition for said autocmd, and means "after a buffer has been written". .vimrc is the file pattern to match. source % is the command, and it means to source the contents of the current file or buffer (don't remember exactly). The command can be interpreted as "When a file named .vimrc has been written, source it". Sourcing is equivalent to loading a file (I imagine there's a :help source for that)
    – Zoe
    Nov 28, 2020 at 22:32

This behaviour is controlled by the showcmd option.


:set showcmd

and see if that brings it back.

  • 1
    Thanks for your answer. But I had this in my vimrc. So I tried other things in vimrc and by disabling wildmenu it was fixed. Then I enabled wildmenu again and nothing changed. Now I don't know what was wrong!
    – Hamon
    Jan 31, 2016 at 20:58
  • 4
    When you edit your vimrc you can execute it in your running vim, using the command :source /path/to/vimrc. But this is not as clean as starting a fresh instance of Vim (because it won't reset any default settings you might have changed on the command line). So I find the cleanest way to test is to have two copies of Vim running, one where I edit my vimrc and another which I restart to test the results. Feb 1, 2016 at 6:18

You must have set showcmd after set nocompatible like this:

set nocompatible 
set showcmd

I don't know the reason but i faced the same problem and this worked with me.

  • 2
    This applies not just to showcmd, but to many settings, as documented in :help 'nocompatible' ;-) If you use a vimrc file, then set nocompatible is already used automatically! So there no need to add this option yourself ;-) Aug 9, 2016 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.