10

I was reading vimtutor and in lesson 2.1 there was this note about typing commands like dw:

NOTE: The letter  d  will appear on the last line of the screen as you type
    it.  Vim is waiting for you to type  w .  If you see another character
    than  d  you typed something wrong; press  <ESC>  and start over.

but I can't see the commands that I am typing in command line neither in vim or gvim. How can I fix that?

2

Add this line into you .vimrc , either source it or restart vim.

set showcmd

And yes If you are experimenting with your vimrc and tired of sourcing it after every change, add this line.

autocmd BufWritePost .vimrc source %
13

This behaviour is controlled by the showcmd option.

Try:

:set showcmd

and see if that brings it back.

  • 1
    Thanks for your answer. But I had this in my vimrc. So I tried other things in vimrc and by disabling wildmenu it was fixed. Then I enabled wildmenu again and nothing changed. Now I don't know what was wrong! – Hamon Jan 31 '16 at 20:58
  • 4
    When you edit your vimrc you can execute it in your running vim, using the command :source /path/to/vimrc. But this is not as clean as starting a fresh instance of Vim (because it won't reset any default settings you might have changed on the command line). So I find the cleanest way to test is to have two copies of Vim running, one where I edit my vimrc and another which I restart to test the results. – joeytwiddle Feb 1 '16 at 6:18
1

You must have set showcmd after set nocompatible like this:

set nocompatible 
set showcmd

I don't know the reason but i faced the same problem and this worked with me.

  • This applies not just to showcmd, but to many settings, as documented in :help 'nocompatible' ;-) If you use a vimrc file, then set nocompatible is already used automatically! So there no need to add this option yourself ;-) – Martin Tournoij Aug 9 '16 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.