0

I am using Vim 7.4. According to vim's help on persistent undo:

An undo file is also ignored if its owner differs from the owner of the edited file. 
Set 'verbose' to get a message about that when opening a file.

Where do I set verbose? In my vimrc I have the following as my persistent undo-related code:

if has("persistent_undo")
  if isdirectory(expand("~/.vim/temp_dirs/undodir"))
    verbose set undodir=~/.vim/temp_dirs/undodir
  else
    echomsg "ERROR: undodir does not exist or is not writable."
  endif

  verbose set undofile
endif

However, when I edit a file of which I am not the owner, I get no such message.

1

The sentence

Set 'verbose' to get a message about that when opening a file.

Refers to the option verbose—you can tell because it's enclosed in single-quotes, and if you place your cursor on it and press Ctrl-], you jump to the same section as :help 'verbose' would.

It's not clear what level of verbosity you would need, but try

set verbose=1

and then increase from there.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.