0

I want to see trailing white space differences using internal diff. By default vim uses iwhilteeol. Is there a way to turn this option off?

1

My vim doesn't use iwhiteeol by default:

                        *'dip'* *'diffopt'*
'diffopt' 'dip'     string  (default "internal,filler")
            global
            {not available when compiled without the |+diff|
            feature}
    Option settings for diff mode.  It can consist of the following items.
    All are optional.  Items must be separated by a comma.

But to disable it:

set diffopt-=iwhiteeol

You can also

set list listchars^=trail:.

to show trailing whitespace

| improve this answer | |
  • I know how to disable an option. My diffopt is blank, but diff still ignores trailing white space. – user1602 Nov 22 '19 at 6:28
  • 1
    @user1602 that should fix your issue. Diff or vimdiff, just to be clear? You might see our post on debugging your vimrc – D. Ben Knoble Nov 22 '19 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.