2 votes

tabs after pastetoggle instead of spaces

I only use paste mode when I want to paste the origin text without modifying anything.(like indenting) After pasting, I leave paste mode and starting editing. IMO, you should not hack paste mode, ...
Lotus's user avatar
  • 21
2 votes

Setting TAB to 2 spaces

This should fix your problem. It has more options, but two first lines are most important. set tabstop=2 softtabstop=2 shiftwidth=2 set expandtab set number ruler set autoindent smartindent syntax ...
Sysadmin's user avatar
  • 121
2 votes

Why is Vim ignoring my `expandtab` setting?

As you figured out, the problem was that the option was set as a result of setting another option. I opened an issue about this, and the Vim developers sprang into action and fixed it a few days later....
Rich's user avatar
  • 32k
1 vote
Accepted

Why is Vim ignoring my `expandtab` setting?

The problem was that I had set binary in my vimrc from years ago. Removing this option fixed the problem. The Vim documentation says that binary will set expandtab (among other settings) to off. ...
Wil's user avatar
  • 21

Only top scored, non community-wiki answers of a minimum length are eligible