2

I downloaded the glsl syntax file and installed it on my computer (a personal folder) Where did you install the syntax file? Make sure it's located in your ~/.vim/syntax/ directory. and then added the following auto-load line to my .vimrc: The :source command is wrong in this context: au BufNewFile,BufReadPost *.shader,*.frag,*.vert,*.fp,*.vp,*.glsl ...


2

For (1), you need to change the value of g:vim_json_warnings before the syntax file runs, such as in your vimrc. As you point out, there is a way to force the syntax files to reload on-demand, so you can change the variable and then :edit to have the changes take effect.


1

As far as I can tell the term for that feature is inline diagnostics. I don't see any obvious source (like neovim help) for an answer to how to disable it but I found these two possible solutions: vim.lsp.handlers["textDocument/publishDiagnostics"] = vim.lsp.with( vim.lsp.diagnostic.on_publish_diagnostics, { virtual_text = false } ) ...


Only top voted, non community-wiki answers of a minimum length are eligible