Hot answers tagged

6

That is not how the clipboard works in Unix land. Basically when the clipboard content is requested, it means a client requests from the X-Server the selection of the clipboard from whoever owns it. The X Server will then relay this request to the other X client, that owns the clipboard. Now, obviously, this does not work, if you quit the X client, that ...


4

This should be fixed in the release after 0.2.2. This was reported in neovim/neovim#7641 and the issue was that st's terminfo incorrectly specifies how to change the cursor shape. The fix in neovim was to ignore what st reports and use the typical values for those escape sequences.


2

SOLVED! The problem was the background variable, which was set to dark. set background=light solves the issue.


1

You need to tell Tmux how to translate the control sequences sent by Nvim to the outer terminal, here st. This is done by setting the unofficial extensions to terminfo Ss and Se. From man tmux: Ss, Se Set or reset the cursor style. If set, a sequence such as this may be used to change the cursor to an underline: $ printf '\033[4 q' ...


Only top voted, non community-wiki answers of a minimum length are eligible