4

SpaceVim uses leaderqr instead of q because it remaps q to another function. As far as I can tell from the documentation, @ is not used for another function: so you play back macros in the usual way: @letter


3

In SpaceVim, we use g:spacevim_relativenumber to config relativenumber. if by default it is 1, if you want to disable this feature. just add let g:spacevim_relativenumber = 0 to your custom config. the config can be opened via SPC f v d. why we make this option enabled by default? because relativenumber is very useful for line move, you can use 7j to move ...


3

As author of SpaceVim, I can not reproduce this issue in master branch. and we do not map j and k in spacevim. I think you should check result of :verbose map j or :verbose map k, this command will show what and where j and k is mapped. if the result is empty, you need to check autocmd like CursorMoved via :au CursorMoved, the output will what autocmd will ...


3

Disclaimer: I'm the author of vimtex. You should not use both vimtex and vim-latex at the same time. They are filetype plugins that try to implement the same set of features, at least partially. For some more information about the difference between the plugins, you can read some of the answers here: What are the differences between LaTeX plugins? That ...


2

In SpaceVim, all layers is a list in g:spacevim_plugin_groups. you can remove item in it. but it is not better way to remove layers. we will Update document about layer config. please check out the PRs in spacevim repo. Thanks!


1

I think I can make a guess (but I have never seen this before either, and I haven't used SpaceVim yet) based on this issue: gq for reformatting doesn't work #787. nmap g [G] essentially blocks all the usual normal-mode commands that start g. gq, for example, is now [G]q. nnoremap gf gf, by virtue of being a noremap version, blocks further mapping expansion, ...


1

I have exactly the same problem. It seems that SpaceVim overrides the gf command in some way so that rails-vim plugin's gf doesn't check for _ on partial names anymore. Also, you have to be on the partial name itself (instead of anywhere on the same line, thanks to vim-ruby plugin) for gf to work. So maybe it messes with vim-ruby too.


1

SpaceVim provides new key binding for async searching. it is SPC s J, the result will be put into quickfix list.


1

In SpaceVim, the default layer contains checkers layer which is using neomake, you can read :h neomake to config your pylint maker. in neomake the default pylint confg is: function! neomake#makers#ft#python#pylint() abort let maker = { \ 'args': [ \ '--output-format=text', \ '--msg-template="{path}:{line}:{column}:{C}: [...


1

The problem is not with your vim. What is the responsibility of your vim, is to execute the command after the !. It does it correctly. The error message is from the git. However, it is still not the problem with your git. The responsibility of the git here, is to call another git process on your remote machine by ssh. Git only calls this ssh, and it does it ...


1

Custom config didn't work for me. So I did this: $ find ~/.SpaceVim/ -type f | xargs grep spacevim_relativenumber And found the line in .SpaceVim//autoload/SpaceVim.vim: let g:spacevim_relativenumber = 1 Then I changed this setting to 0. It looks like little bit more generic way that can also be applied to other settings.


1

I am learning light vimscripting, so I am not sure if this will work. But put these in your .vimrc: function! NextLine() let c = col(".") execute "normal! j" . c . "|" endfunction function! PreviousLine() let c = col(".") execute "normal! k" . c . "|" endfunction nnoremap j :call NextLine() nnoremap k :call PreviousLine() These will not give you ...


1

SpaceVim uses a built-in modular status line, which depends on a power line patched font. These fonts include extra symbols that render as arrows in the terminal. You can find pre-patched fonts here: https://github.com/powerline/fonts. I’m pretty sure that repository also has instructions for patching an arbitrary font if none of the fonts it provides are ...


1

Just remove let g:spacevim_custom_plugins=[ \ ['SirVer/ultisnips/', {'on_ft' : 'autocomplete'}], \ ] no need to use custom plugin, just change g:spacevim_snippet_engine is enough. If you still get issue, please use the issue tracker of SpaceVim github repo.


Only top voted, non community-wiki answers of a minimum length are eligible