New answers tagged

1

If you run under *nix (including MSYS2/Cygwin) then you can suspend Vim process with Ctrl-Z (see :h suspend). This will bring you back to the Vim's parent process (i.e. parent shell). Use fg to get back as usual. Won't work under plain Windows.


1

The comments by B layer and Ben Knoble were both helpful in finding the answer. Vim correctly set the shell based on the $SHELL variable, but did not set shellcmdflag appropriately, and that was what the /s was, the default shellcmdflag for cmd.exe, as stated in the :help 'shell' file. Setting it to -c in my init.vim seems to have solved the problem, and a ...


Top 50 recent answers are included