27

One has to realize that the feature implemented by airline are inspired by the powerline plugin. Furthermore, I was relying on the docs too much, not realizing that there is well-written airline help document shipped with itself: :h airline Reading its documentation helps understanding the functionality of this plugin. Font As mentioned in the powerline ...


13

I did the following to install (Although I could copy the whole ~/.vim directory to the new place instead of steps 3-6): Install vim 7.4: brew install vim Note: If you are using mac operating system, make sure you create an alias in your bash_profile pointing to macvim i.e. which mvim Install Vundle Add Plugin 'Valloric/YouCompleteMe' to ~/.vimrc and run :...


12

For a plugin to be Pathogen/Vundle/NeoBundle/Plug/VAM-compatible, it needs to follow the standard structure expected by Vim in your ~/.vim/ directory: STANDARD STRUCTURE PLUGIN STRUCTURE ~/.vim/autoload/... ~/.vim/bundle/pluginname/autoload/... /doc/... /doc/... /ftplugin/... ...


11

First things first; the line below has absolutely nothing to do with Vundle or plugin management: filetype plugin indent on That command does three things: enables filetype detection, enables filetype-specific scripts (ftplugins), enables filetype-specific indent scripts. That line is there because some plugin managers have to make sure filetype ...


9

In your _vimrc delete the Plugin 'blabla' line you want to uninstall. Execute :PluginClean in vim. By the way, make sure PluginClean do the right thing you should open a new vim window to execute :PluginClean


7

You've installed the fzf.vim wrapper plugin, but you haven't installed the base fzf plugin, which provides the underlying functionality, including the autoload functions that the error messages are flagging as "Unknown". Try using: Plugin 'junegunn/fzf' Plugin 'junegunn/fzf.vim'


6

Spelling is the issue. Plugin 'scroolosse/nerdTree' Should be Plugin 'scrooloose/nerdTree' The double s is the clincher. GitHub Scrooloose NerdTree repo


4

Vim parses your .vimrc once when it is started. Whenever you change something in it (in your case add a new plugin), vim needs to be told manually that something changed so that the .vimrc gets parsed again. You do that by running :source $MYVIMRC. I often shorten that to :so % when my .vimrc is opened (% gets expanded to current file name). After sourcing ...


4

The indentation problem comes from the ftplugin, which loads a .vim file from /usr/share/vim/vim-version-/ftplugin/-filetype-.vim that overrides whatever you have in your .vimrc file. you can find out where that file is by running the following command inside vim :verbose set tabstop?. The output will point you to the file that is overriding your ...


3

As it turned out there are common practice to wrap platform specific options in statements which checks the system and set properties accrodingly to this. For some could be convenient to separate such statements into different files. As to me i end up with this: if has("win32") set rtp+=$HOME/vimfiles/bundle/Vundle.vim/ call vundle#begin('$USERPROFILE/...


3

I probably don't know all plugin managers, but most (including vundle), if not all, build on the plugin system that tpope invented with pathogen. This plugin system basically recreates the folder structure you have in ~/.vim. To make it short. They should be interchangeable.


3

I assume you installed Vundle the usual way (git clone https://github.com/gmarik/Vundle.vim ~/.vim/bundle/...). When you initialized a Git repository on .vim, Vundle's directory will be seen as a Git link instead of a Git submodule. This complicates things, since there's no simple way to add the plugins as part of the overall repo. What you could do is: ...


2

The error comes from the fact that Vundle isn't installed on your vagrant VM. You should connect to your VM, issue the following command: git clone https://github.com/gmarik/Vundle.vim.git ~/.vim/bundle/Vundle.vim And issue :PluginInstall in vim on your VM. I think it is possible to use puppet to pre-configure your vagrant installation to include Vundle ...


2

It turns out I had a compiled version of python in /usr/local that I had completely forgotten about, and vim was compiled against that one. I verified this by using :py print(sys.path), which showed directories under /usr/local. I removed the compiled version of python and recompiled vim against the standard version, and all is well.


2

From the Vundle README and from :h vundle-faq too: " git repos on your local machine (i.e. when working on your own plugin) Plugin 'file:///home/gmarik/path/to/plugin' Add these lines to your vimrc and then manage the plugin as the other ones with :PluginInstall and sisters commands.


2

Vundle calls system() to run git. The command will be executed in "cooked" mode, so that a CTRL-C will interrupt the command (on Unix at least). If you cancel Vundle, Vim will interrupt git. So the question is are you able to stop git safely? Since you can find posts about broken git repos the answer is probably no. A better alternative might be vim-...


2

The problem seems to lie in ascenator/l9 plugin. Open it at the lines incriminated and add a ! on all command definitions. The best is to contact its author to have him fix the plugin. The fact you're using using the official plugin and a fork of it certainly doesn't help. Why are you doing this? It gives me the impression you have copy-pasted stuff from ...


2

When you read the error message you can see that the problem comes from ~/.vim/bundle/LaTeX-Suite-aka-Vim-LaTeX/plugin/remoteOpen.vim on line 33. This line is the following: com -nargs=1 RemoteOpen :call RemoteOpen('<args>') It uses :h :command to create the user defined command :RemoteOpen. What Vim says is Command already exists: add ! to replace ...


2

In your .vimrc you're calling vundle#begin() twice and after the second one you're only loading the Vundle plugin. That's probably why it's ignoring the other plugins you have outside that block. You're also missing the call to vundle#end() and re-enabling the filetype detection. Take a look at Vundle's quick start again to see what your .vimrc should look ...


2

If you are already using symlinks to set up your Vim configuration, and if — as I infer from your comments — the only operating system dependent part of your current config is your Vundle setup, then you don't actually need any special code in your vimrc: Windows Command Line :: You'll already be setting up this symlink ...


2

If you are not using git to manage the plugin you are developing, you can use the pinned option. I myself use this option for a plugin which I could only obtain as a zip archive Plugin 'vim-specky', { 'pinned': 1 }. I downloaded the zip file and extracted it under ~/.vim/bundle and added this line in my ~/.vimrc and things are working fine. From the docs of ...


2

As I don't know where to find the "written" rules, I digged into the source code instead. Also note that there are both Vim and Neovim, but it looks that they still share almost the same code in this regard, so the following applies to both. Also, let me remind that there is rtp-order and load-order, and they are different, as it becomes clear from ...


1

I dont know if this would help. So far it helped me. First I went to .vim/bundle/Vundle.vim Then I just do "git pull origin master" to pull latest code from the repo. If there is a merge conflict, settle the conflict and pull again. I dont know why, but while you are pulling from the repo, you have to quit any active editting mode on .vimrc After that, I ...


1

Try to change your Plugin 'gmarik/Vundle.vim' to Plugin 'VundleVim/Vundle.vim' and reinstall VundleVim from: git clone https://github.com/VundleVim/Vundle.vim.git ~/.vim/bundle/Vundle.vim 'gmarik/Vundle.vim' is now hosted as 'VundleVim/Vundle.vim' (From Vundle.vims README)


1

If you want to make it opt-in, do not use a config file that is searched for by Vim. The user should create a .vimrc containing a single line: source /path_to_your_custom.vim


1

Well, so after some investigation I finally located a vundle file. It start from a lower-cased letter and that's why I did not find it at the first place. It's located in /usr/share/vim/vimfiles/autoload/vundle.vim folder. To make vundle work with such a setup, the following tweaks to a config from vundle repo are necessary: ... set rtp+=/usr/share/vim/...


1

Below left is downloaded zip format of a plugin, right is created by 'get clone https://plugin/path' command in Git Bash. Left is equivalent to the plugin you wrote locally. Although the plugin itself is the same, 'get clone' command will also create .git directory which contains git repo files. If install the left side plugin, Vundle will complain "does ...


1

Please add the following to your .vimrc syntax on colorscheme dracula


1

I just made this mistake! :-) # BAD Plugin 'file:///Users/jamesjones/src/github/burnttoast256/colors' # GOOD Plugin 'file:///Users/jamesjones/src/github/burnttoast256' You want to point to the root of the git repo for your plugin, not a subdirectory within your repo, i.e., where the .git directory is.


Only top voted, non community-wiki answers of a minimum length are eligible