4

Neomake runs a user autocmd called NeomakeFinished when it's done. It sets the context variable: g:neomake_hook_context.file_mode. If it's 1 it's using the location list. If you only want it to run when it's finished with a project: autocmd User NeomakeFinished if !g:neomake_hook_context.file_mode | cwindow | endif There is also an option: *g:...


4

I don't know first hand if it works with your fork but the following snippets works perfectly in real Vim: augroup qf autocmd! " automatically open the location/quickfix window after :make, :grep, " :lvimgrep and friends if there are valid locations/errors autocmd QuickFixCmdPost [^l]* cwindow autocmd QuickFixCmdPost l* lwindow ...


4

I just had the same problem as soon as I started adding options, I had to copy the error format from the plugin code to my options: let g:neomake_python_flake8_maker = { \ 'args': ['--ignore=E221,E241,E272,E251,W702,E203,E201,E202', '--format=default'], \ 'errorformat': \ '%E%f:%l: could not compile,%-Z%p^,' . \ '%A%f:%l:%c: %t%n %m,...


3

Well, I finally found the answer myself, and figured I'd leave this as documentation for others. Problem: You want to use GCC as your only maker for C files. You set up Neomake and (Neo)vim the 'obvious' way, but it doesn't do any checking. Solution: There's a couple of things involved here. Firstly, you need to ensure that (Neo)vim doesn't decide ...


3

There is an open issue: Do not run makers on :wq The workaround mentioned in that issue: autocmd! QuitPre * let g:neomake_verbose = 0


2

In my case I setup all my dev environments like a virtualenv, using pyenv. For errors and warnings, I put pylama inside my virtualenv (come in my requirements.txt) and pylama requires mccabe, pep257, pep8 and pyflakes. All this are probed by neomake. With this setup, pylama give me alerts from all these integrated, no extra settings needed. But I must ...


1

SpaceVim uses neomake by default: to make neomake support this feature, you can create a .clang file in the root of your project. Please read the lang#c layer doc.


1

Some [lightly edited] info from the comments: Actually this might be the reason for empty Quickfix window. On your screen cast when you run :lopen, Neomake runs for that buffer due to the autocmd for BufEnter. It should be additionally limited to JavaScript files only: augroup neomake au! autocmd BufWritePost *.js Neomake augroup END


Only top voted, non community-wiki answers of a minimum length are eligible