Intellisense engine for vim8 & neovim, full language server protocol support as VSCode

For questions about coc.nvim

What is it?

A plugin that

  • Provides APIs that work on both vim8 and neovim
  • Loads VSCode like extensions
  • Is configured via jsonc configuration file
  • Configures language servers that implements LSP

Use this tag if you have a question about

  • the plugin's usage
  • customizing the plugin
  • configuring the plugin

Do not use this tag if

  • the plugin is irrelevant to your question
  • you want to file a bug about the plugin (use its issue tracker)
history | excerpt history