60

At first I too didn't understand what needs to be done to get this nice looking toolbar. Yes I know about the README and other stuff, but I think there should be a getting started or minimum settings section in the help file. Anyway here are the settings. Installing the appropriate fonts You need to install fonts into your system with symbols like branching, ...


26

One has to realize that the feature implemented by airline are inspired by the powerline plugin. Furthermore, I was relying on the docs too much, not realizing that there is well-written airline help document shipped with itself: :h airline Reading its documentation helps understanding the functionality of this plugin. Font As mentioned in the powerline ...


17

Put the following in your .vimrc: let g:airline_theme='base16' You'll also need to install the vim-airline/vim-airline-themes plugin.


14

This is an inherent issue with the tab metaphor and every solution introduces more problems: multiple lines are harder to parse and take up too much space, tab groups make it impossible to see what's in them at a glance and thus defeat the whole purpose of having a tab-line, arrows to scroll the tab-line are also very impractical and contrary to the purpose ...


13

From the README: Integrating with powerline fonts For the nice looking powerline symbols to appear, you will need to install a patched font. Instructions can be found in the official powerline documentation. Prepatched fonts can be found in the powerline-fonts repository. Finally, you can add the convenience variable let g:...


9

That symbols stands for the last line number. So if it displays: 1/10 ☰ you know that you are on line 1 of 10 lines. BTW: this symbol is in the documentation, search for maxlinenr.


7

No, it's impossible to hide the command-line. -- EDIT -- You can prevent Vim from echoing "filename" XXXL, XXXC when editing a file by prepending silent to e: :silent e foo


7

This took hours to figure out, so here's more of a dummies guide for Fedora/Ubuntu, with a special section for Windows. The first is figuring out what the hell are those strange but nice angle brackets that appear in the vim-airline status bar. The background is that airline is a pure vim version of powerline (which was python), and powerline uses UTF-8 ...


6

The README of a project is not meant to be a complete documentation, generally it is worth reading the doc. For example: :h airline-advanced-customization ------------------------------------- *airline-parts* A part is something that contains metadata that eventually gets rendered into the statusline. You can define parts that contain ...


5

See this post. Specifically, paste this into your .vimrc." air-line let g:airline_powerline_fonts = 1 if !exists('g:airline_symbols') let g:airline_symbols = {} endif " unicode symbols let g:airline_left_sep = '»' let g:airline_left_sep = '▶' let g:airline_right_sep = '«' let g:airline_right_sep = '◀' let g:airline_symbols.linenr = '␊' let g:...


5

Vim provides 3 concepts for working with multiple files: Buffers: one for each file you've opened. Windows/Splits: view multiple things at the same time. Tabs: For multiple sets of windows. Useful for managing multiple tasks. By conflating them all into the same thing, you're losing out on a lot of power. You should consider other ways which you can use ...


4

I finally found a way to get rid of the command, mode as well as file name in the command line bar! at the bottom of your .vimrc: set noshowmode " to get rid of thing like --INSERT-- set noshowcmd " to get rid of display of last command set shortmess+=F " to get rid of the file name displayed in the command line bar notice that this piece of code ...


4

So this has to do with the fact that: vim . Opens the current directory into a netrw buffer that is not unlisted. This is what causes odd behavior with :bp/:bn. If I :bdelete 1 soon as I open vim on a directory, then I don't have this issue for the rest of the session. Alternatively: vim +':Ex' Does effectively the same thing but with the netrw buffer ...


3

I remember having a similar problem. I never really solved it but worked my way around it by installing the Hack font and by putting the following in my .vimrc: set guifont=Hack:h10:cANSI " Airline let g:airline_powerline_fonts = 1 if !exists('g:airline_symbols') let g:airline_symbols = {} endif " unicode symbols let g:airline_left_sep = '»' let g:...


3

From issue#225 of cmder: This not a specific problem of cmder, but rather of cmd in general, which does not use UTF-8 by default. So just run chcp 65001 from cmder terminal to set unicode code page to UTF8. BUT this way you should run this code every time you are going to use cmder; To automate this: You can just add a "@chcp 65001 >nul" at the ...


3

I solved the first two problems by putting the set t_Co=256 in my .vimrc and solved the missing upper bar problem by putting this in my .vimrc. let g:airline#extensions#tabline#enabled = 1 " Show just the filename let g:airline#extensions#tabline#fnamemod = ':t'


3

According to Christian Brabandt this is how airline works. He created a solution that requires setting the variable let g:airline_skip_empty_sections = 1.


3

The orange section by default should be the warning one: let g:airline_section_warning (ycm_warning_count, whitespace) You can find a list of all sections at the end of the 'CUSTOMIZATION' section of the airline help (:help airline-customization). It gets filled usually by the whitespace extension which is on by default. Use the following in you vimrc ...


3

It's a short-hand describing your path. I.e. if you path was: Some/Long/Path/file.txt The resulting tab would end up looking like: S/L/P/file.txt


3

(not using Airline, guessing from the documentation) You can add the following to your status line and it will show the content of the register +: set statusline+=%{@+} Then you have different choice in airline (also guessing from the doc): From add_statusline_func: let w:airline_section_b = '%{@+}' From airline-sections: let g:airline_section_c = ...


3

I had the same issue after reinstalling Vim: my old patched fonts were not compatible with the new airline symbols. The old symbols are also mentioned in the help (:help airline-customization): " old vim-powerline symbols let g:airline_left_sep = '⮀' let g:airline_left_alt_sep = '⮁' let g:airline_right_sep = '⮂' let g:airline_right_alt_sep = '⮃' let g:...


3

Outside of :set showcmd, there's no way to programmatically access the currently typed command, so there's no chance to have airline (or any other plugin) display it, unfortunately.


3

Per :help airline, the default value of things airline will filter out of the buffer list if not otherwise specified by the user is: let g:airline#extensions#tabline#ignore_bufadd_pat = '!|defx|gundo|nerd_tree|startify|tagbar|term://|undotree|vimfiler' ...where ! and term:/ are the respective ways of identifying terminals in VIM and Neovim respectively. ...


3

It's probably one of two things: The cmdheight setting is 2 or higher; you can check the current value with :set cmdheight?, and set it to the default of 1 with :set cmdheight=1. There's something in your vimrc or a plugin changing from the default, you can use :verbose set cmdheight? to see where it was last set. The terminal screen isn't quite big enough ...


2

With like 5min work reading :help airline I now realize airline is super customizable. I added the following to my .vimrc which replaces the line number percentage 33%  44: 2 (which I never use) with the current filename: let g:airline_section_z = '%t'


2

You hide the redundant line by setting laststatus to 1. Then airline goes away unless you have a split. You might be able to make airline set the rulerformat or set it to something else you like (and you probably need to set ruler as well).


2

You should try adding the following line in your vimrc : let g:airline#extensions#whitespace#mixed_indent_algo = 1 Also, some fonts may work better than others. e.g. : http://larsenwork.com/monoid/ https://github.com/powerline/fonts/tree/master/Inconsolata


2

For me, I use let g:airline_symbols.maxlinenr= ''


2

I've found the correct option: Open .vimrc Add let Tlist_Enable_Fold_Column=0 It's now good ;-)


2

Looking at the image you commented on Octaviour's answer, I realise it is similar to a problem that I had for setting up vim-airline. Sure, I installed the Powerline fonts, but those weird symbols still appeared. To fix this, I added the line export LANG=en_US.UTF-8 at the end of my /etc/profile by editing it as root. I am not really sure as to how this ...


Only top voted, non community-wiki answers of a minimum length are eligible