New answers tagged

1

It looks like selecting something from that window leads to Windows doing Ctrl+V in an attempt to paste. That, of course, doesn't mean the same thing in Vim. However, if you have things properly set up to catch clipboard text in register * (see :h 'clipboard') then all you'd need to do after clicking an item in the window is hit p in Vim. (If that doesn't ...


0

zipPlugin shipped with Vim is poorly customizable. All command-line flags are hardcoded and cannot be changed. So there won't be any nice solution. Except maybe patching plugin's source code, or writing some wrapper shell script to re-translate option flags etc.


1

Thanks to comment of muru. Solved the problem using https://vi.stackexchange.com/a/3729/33095 :nnoremap <Leader>w <C-w> Unless you've remapped , you can now use \w (after each other). I actually prefer this since I don't like CTRL+key combinations. and/or using https://vi.stackexchange.com/a/3737/33095. I actually use :wincmd more often than ...


0

I think it might just be a terminal issue.. If you launch ubuntu or whatever system you use, the border is still there. Just that ubuntu is more zoomed out. Check this out: https://stackoverflow.com/a/33844542/14804431


1

It looks like you had the 'shellpipe' option misconfigured to just a | instead of a | tee (which would work on Linux/Unix/WSL) or > (which would work on Windows.) You can find the value this option is set to and the origin of this setting with: :verbose set shellpipe? As discussed in the comments, resetting this option to the Windows default worked to ...


0

filenameescape() is supposed to be the solution. And yet, I've cooked my own solution 2 decades ago and it's still working fine so far. function! lh#path#fix(pathname, ...) abort " Parameters {{{4 " Ignore the last slash or backslash character, if any let pathname = matchstr(a:pathname, '^.*[^/\\]') " Default value for the ...


1

Two solutions: On a current windows 10 machine that I have access to for work with a user account only, I was able to sucessfully install the standard vim version, named 'self-installing executeable' that is available here: https://ftp.nluug.nl/pub/vim/pc/gvim82.exe Administrator access was not required. This version comes with an autoload folder (unlike ...


Top 50 recent answers are included