24

Ok. Apparently on native vim in Arch there is no support for X so the +clipboard feature is missing. To fix this, install gvim, which although conflicts with vim, which was my initial problem with it, retains the exact same functionality if you use vim Rather than, gvim You still need to set clipboard=unnamed.


9

First off, Vim can only display a file in a single font, you can't use multiple fonts at the same time. For gVim, you can use guifont to set this to Font Awesome: set guifont=Font\ Awesome\ 14 Which seems to work fine. For Terminal Vim, you will need to configure your terminal emulator to use Font Awesome. For xterm, this doesn't seem to work, for gnome-...


8

That line: n indent on means "open the file called indent that is at the root of the working directory". Basically, you tell Vim to do something silly and… it does just that. It should be: filetype plugin indent on Be more careful about what you copy and paste.


6

Thanks to x33a on the Arch forums, I was able to solve my problem. (https://bbs.archlinux.org/viewtopic.php?pid=1596987#p1596987) I changed the python 3 flag from --enable-python3interp=dyanmic to --enable-python3interp This resulted in only python 3 being available.


4

I unknowingly had installed on my system the set of packages "vim-plugins". Among these was "vim-jedi" which seems to be the one causing behavior I didn't want. I used the package manager to remove it. Thanks very much for the commenters who helped me diagnose this!


4

The problem was not in Vim's default Python interpreter. The real root of the problem is that the last version of jedi-vim (0.7.0) was released in 2013 and did not work well with Python 3. Since then Python 3 support in jedi-vim has been improved a lot. We (Arch users) asked jedi-vim to make a new release. 0.8.0 has been released and now it is in the Arch ...


4

If the background is changing, then the colorscheme is changing it. You can either choose a colorscheme that doesn't do that, or try overriding the colorscheme. autocmd ColorScheme * highlight Normal ctermbg=NONE guibg=NONE The colorscheme may be designed around a particular background color, though, and there may be other highlight groups which need ...


3

Console Vim is using the font from the console terminal. You can use Inconsolata Nerd Font, which includes FontAwesome glyphs. For example, in urxvt including the following: URxvt.font: xft:SF Mono:size=12,xft:Inconsolata Nerd Font Mono:size=11 URxvt.letterSpace: -1 More on Font Awesome's github from this closed issue.


3

I feel like an idiot. The test file doesn't have any non-ASCII characters in it, so there is nothing for file to look for that would tell it the encoding Vim is using. So I repeated the test with ä in it and it returns "utf-8" as desired. In short, file was doing its best, and Vim was doing what I wanted it to do.


2

As suggested by filbranden in the comments, I workarounded the issue by installing Vim from Arch package repository. Not that I had not tried, but the package vim, as you can read here, does not come with the +clipboard feature, hence my attempt to build it from source. It truns out that the package gvim does come with that feature, so installing it solved ...


2

As of patch 8.1.2350, Ctrl-V will emit again the translated key, even if modifyOtherKeys has been set. To get the raw escape sequence, you can instead use now Ctrl-Shift-V


1

Add this to your vimrc: set t_fd= set t_fe= Some terminals including xterm support the focus event tracking feature. If this feature is enabled by the 't_fe' sequence, special key sequences are sent from the terminal to Vim every time the terminal gains or loses focus. Vim fires focus events (|FocusGained|/|FocusLost|) by handling them accordingly. Focus ...


1

set t_TE= t_TI= This in vimrc disables modifyOtherKeys (:h modifyOtherKeys), which was causing the problems


1

As mentioned in the comments, you need to make sure cpoptions does not contain the k and < flags before defining your mappings (this explains why netrw broke too). The likely culprit is that vim was running in compatible mode (this should not be the case if you have a .vimrc file, but it's possible to do some funky things with the invocation to end up in ...


1

I worked around this problem by using the compile switch: --disable-netbeans However, obviously it is just a workaround and the test failure will be a problem for anyone that wants to use netbeans with compiled vim.


1

One thing I've just seen is that if cpo contains <, then special characters like <leader> won't be handled right: *cpo-<* < Disable the recognition of special key codes in |<>| form in mappings, abbreviations, and the "to" part of menu commands. For example, the command ...


1

Well, so after some investigation I finally located a vundle file. It start from a lower-cased letter and that's why I did not find it at the first place. It's located in /usr/share/vim/vimfiles/autoload/vundle.vim folder. To make vundle work with such a setup, the following tweaks to a config from vundle repo are necessary: ... set rtp+=/usr/share/vim/...


Only top voted, non community-wiki answers of a minimum length are eligible