Hot answers tagged

11

Main Issue The main problem you are experiencing is caused by the ordering of the commands in your .vimrc. You set the g:impact_transbg variable after you load the colorscheme, and so the variable does not exist when checked by the colorscheme's if statement, and the second version of the colorscheme (in the else block) is used. To fix, you simply need to ...


10

Ah, I found the culprit by bisecting my .vimrc file. I had mapped Escape in normal mode to clear search highlighting: " Clear highlighting on escape in normal mode nnoremap <esc> :noh<return><esc> However, that will confuse vim as it tries to parse the mouse's escape codes. So what I ended up doing is taking the solution from this answer, ...


7

A quick rundown on colorschemes See :help :colorscheme. Essentially it sources a file containing :highlight commands. What are highlight commands? Statements of the form :hi[ghlight] [default] {group-name} {key}={arg} .. that highlight sections of code (when syntax highlighting is enabled with syntax enable) and sections of the UI. They can set special ...


7

In the case of Neovim, t_Co and TERM make no difference. You are calling set background=darkbefore and after the call to colorscheme impact3. Move set background=dark to the bottom of the colorscheme, and remove the other call from your vimrc. From :help 'background': When 'background' is set Vim will adjust the default color groups for the new value. ......


6

This is not due to vimtex directly, but due to the conceal feature in Vim. vimtex only adds to the syntax plugin that ships with Vim/neovim, and it adhers to the relevant option, see :help g:tex_conceal. For direct control of the conceal feature itself, see :help conceallevel, :help concealcursor and :help syn-conceal. Short answer, you can put the ...


5

Terminal Vim has no control over, or knowledge of, the line spacing that is currently being used in the terminal within which it is running. It just sends characters to the terminal (in your case, iTerm2), which renders them according to its own settings. There isn't, therefore, a clean way to do this. What you can do, however, is tell iTerm2 to switch ...


4

Turns out this was a bug in Vim itself. The problem is resolved as of Vim 7.4.1942.


4

Basically when you paste using cmd + V, it is just throwing the content of the macOS clipboard at vim. It is just like typing each character that is in the clipboard literally into vim. That sometimes works, but often it doesn't. So the use is discouraged. For this purpose there is the "* and "+ registers which use the system clipboard and paste the content ...


3

It's probably one of two things: The cmdheight setting is 2 or higher; you can check the current value with :set cmdheight?, and set it to the default of 1 with :set cmdheight=1. There's something in your vimrc or a plugin changing from the default, you can use :verbose set cmdheight? to see where it was last set. The terminal screen isn't quite big enough ...


3

You have to run the script when your shell starts and it has to be ran from the base16-vim color scheme, which is tersely documented in base16-shell. But, you don't want to use that script. It'll just create more confusion later. The "base 16" colors are the 8 standard colors + 8 brighter variants of those colors. base16's themes treat them as 16 ...


2

You're missing an awesome NeoVim feature. There's an env var that helps with this stuff. Try putting this in your nvimrc: let $NVIM_TUI_ENABLE_TRUE_COLOR=1 " True gui colors in terminal Or export NVIM_TUI_ENABLE_TRUE_COLOR=1 in the shell.


2

I see you use iTerm2, so you can try this: Open prefernces window ⌘+, Go to profiles tab Check your current profile in the left list Click on the tab terminal at right In the Report terminal type choose xterm-256color Done.


2

You need to set up options let $NVIM_TUI_ENABLE_TRUE_COLOR=1 set termguicolors in your .config/nvim/init.vim.


2

Sorry, it's because I set :set ambiwidth=double. It makes some characters twice as wide as usual. I set :set ambiwidth=single, and all is fine. This line, I must have copied from some stranger's vimrc and did not examine closely. It's my fault, not Vim's fault. I have no idea what ambiwidth is for. Maybe there is some font that need it to display right (see ...


2

Quoting from Bram: I assume you are talking about the command line, or entering search. Yes, it's intentional that the line break does not work like pressing Enter. The idea is that you are pasting text, not a command. You are supposed to view the text before deciding to execute it. The thread that started it mentioned that the source of the text ...


2

You should also include: highlight ErrorMsg cterm=NONE The cterm attributes often interact with the color settings and can end up having Vim picking a "bright" shade of the color. The "koehler" theme ships with cterm=bold, which has this effect of using a bright color on many terminals, including iTerm2 (with default settings.) You can inspect your ...


2

I think would be useful a "Toggle" mapping that allows us to swich concealling level: nnoremap <Leader>c :let &cole=(&cole == 2) ? 0 : 2 <bar> echo 'conceallevel ' . &cole <CR>


1

I fixed it by sliding minimum constrast bar in iterm2 profile.


1

Solution Setting LANG to tr_TR.UTF-8 did solve the issue. export LANG=tr_TR.UTF-8 Problem Turns out LANG being empty was the root cause: > locale LANG="" LC_COLLATE="C" LC_CTYPE="UTF-8" LC_MESSAGES="C" LC_MONETARY="C" LC_NUMERIC="C" LC_TIME="C" LC_ALL= I only checked through ...


1

Thanks to your output of verbose inoremap <c-h> it's really easy to see what is happening here! You are using the auto-pairs plug-in and it's installing buffer-local mappings for the bracket keys, but also for keys such as Enter and Backspace. It maps backspace so it can "undo" a close bracket action if you type backspace to erase a mistake of yours. ...


1

I agree any answer to this question will be somehow subjective, but I also agree with Eyal Karin that there may be an objective component too. I've been using the Neovim terminal as my main terminal for at least two years now, maybe more, even while SSH to a remote machine, and despite its rough edges, I cannot go back to a dedicated one, not because my ...


1

This happened to me, and it was because I configured my colorscheme colors after I actually set the colorscheme. Moving my colorscheme command to a line after the actual color configuration solved my problem.


1

SpaceVim uses a built-in modular status line, which depends on a power line patched font. These fonts include extra symbols that render as arrows in the terminal. You can find pre-patched fonts here: https://github.com/powerline/fonts. I’m pretty sure that repository also has instructions for patching an arbitrary font if none of the fonts it provides are ...


1

You apparently copy and pasted some html code into your colorscheme file. If you open the file in github, click on the RAW link and copy paste again and make sure to overwrite the previous version. (Even better would be to simply download that file using wget or similar)


1

The most likely scenario is that the the colour scheme is changing correctly, but that Vim isn't actually displaying the colours anywhere because you don't have syntax highlighting enabled. Try running the command: :syntax on If that fixes it, you can add it to your vimrc file. As @13312 hints, it's also possible (but unlikely) that Vim believes itself ...


1

Get yourself a proper Vim with clipboard support. Place the bundled mvim script somewhere in your $PATH. Add an alias to your ~/.bashrc or whatever init file is used by your shell: alias vim='/path/to/mvim -v' Use "+y and "+p to yank to and put from the system clipboard.


1

How about nnoremap <ScrollWheelUp> k nnoremap <ScrollWheelDown> j ? I can't test on osx though, but it works on my linux installation.


1

Note that the specific color scheme is really two sets of color schemes within an if-else clause. The existence of the variableg:impact_transbg selects the desired set of colors, and was originally intended to account for transparent backgrounds in the color scheme from which this is derived. Commenting out the 2nd color scheme and the if-else statement (...


Only top voted, non community-wiki answers of a minimum length are eligible