New answers tagged

0

Is this a NeoVim bug, am I doing something wrong or is my configuration flawed? After further investigation this does not appear to be a NeoVim bug; therefore I must have been doing something wrong or had configuration snags. An issue was raised on the NeoVim repository, and subsequently closed as the bug could not be replicated. I subsequently booted up ...


2

Vim 8.1.2250 does not ship with filetype detection for solidity. (One can confirm with :edit $VIMRUNTIME/filetype.vim and then :global /sol/.) ALE has Solidity linters, but they require the filetype to be set. The simplest solution is to create ~/.vim/ftdetect/solidity.vim and add au BufNewFile,BufRead *.sol setfiletype solidity However, this plugin ...


1

The fact that you are getting this message on your verbose log file is expected. The Vim source code has an explicit comment about that: /* * When using ":silent! cmd" ignore error messages. * But do write it to the redirection file. */ I linked to the code in Vim 7.4, but Vim 8.2 still has the same exact snippet and exhibits the same behavior. I ...


0

is there a better way to set filetype off than the filetype off command? filetype is off by default in Vim (but note: no vimrc means sourcing defaults.vim which does enable filetype). Therefore, you should just remove the 2nd line. So it appears there is an error in ftoff.vim? silent! stands there to shut up any error if filetypedetect does not exist (...


Top 50 recent answers are included