New answers tagged

1

By default, Vim menus are only enabled in the GUI version of Vim. So if you use GVim on Linux you should see the menus and the menus added by plug-ins such as those from vim-latex will be available too. You can enable menus on the terminal, but you need to do so explicitly. See :help console-menus: Although this documentation is in the GUI section, you can ...


1

A couple of other tips-n-tricks: with tpope/scriptease, you can use :Vedit (and other variants) to fill the location list with all runtimepath entries matching the provided file (e.g., :Vedit ftplugin/tex.vim) to actually put an autocommand on a specific filetype, such as "automatically run :Require on clojure files when they save," you can use a &...


4

Vim will load filetype-specific commands from an ftplugin. See :help ftplugin. In short, you can create a file under ~/.vim/ftplugin (or %HOME%\vimfiles\ftplugin on Windows), or better ~/.vim/after/ftplugin (or %HOME%\vimfiles\after\ftplugin) named after the filetype for which it should be loaded. For example, when a file is detected with filetype=tex, Vim ...


1

The problem you're having is that your file is being recognized as filetype=plaintex, which means TeX (or '"plain" TeX) and not LaTeX, and the latex-suite plug-ins only enable most of their commands on LaTeX files. LaTeX files are identified by filetype=tex (which can indeed seem quite confusing.) Since files with the extension *.tex can be TeX or ...


Top 50 recent answers are included