13

This behavior seems to come from calling git commit -v or git commit --verbose. Not sure where you're doing that in your dotfiles, but I'd recommend telling him to set an alias in his git config that does that.


7

If I run :set spell, I get: spellfile#LoadFile(): There is no writable spell directory Shall I create /Users/adamharris/.nvim/spell (Y)es, [N]o: Select y Cannot find spell file for "en" in utf-8 Do you want me to try downloading it? (Y)es, [N]o: Select y, and it will download the file. In which directory do you want to write the file: 1. /Users/...


6

Here is how I solved the problem, by adding to my .vimrc: autocmd FileType gitcommit set nosmartindent | set formatoptions-=t This removes the option that causes the lines to auto-wrap (which is another tweak I also made -- take out the last part including the | if you do not want to change this). The take-away here is that nosmartindent is the trick to ...


3

Alternatively you can use Tim Pope's fugitive.vim. It provides :Gcommit which is a wrapper around git commit (So you can do :Gcommit --verbose). Probably the more preferred way would be to use :Gstatus and execute cvc. Then just create your commit message and then save and quit (I use :x). For more help with fugitive.vim I recommend Vimcasts episodes ...


3

Additionally, Do try out committia.vim, a plugin for writing a commit message. When git commiting, it splits the window and shows the diff and status window very nicely.


Only top voted, non community-wiki answers of a minimum length are eligible