6

The solution is described in the manual: If you just want a highlighted message use :echohl. And to get a beep: :exe "normal \<Esc>" Thus: function! PrintError(msg) abort execute 'normal! \<Esc>' echohl ErrorMsg echomsg a:msg echohl None endfunction


5

Use :compiler!. From :h :compiler: :comp[iler][!] {name} Set options to work with compiler {name}. Without the "!" options are set for the current buffer. With "!" global options are set.


4

Try the following: :set errorformat=%A%f:%l:%c:%m,%-G%.%# The final %-G%.%# acts as a "catch all" clause, that ignores all lines, that are not matched by previous expressions. The following should also work: :set errorformat=%A%f:%l:%c:%m,%-G\\s%#,%-G%*\\d\ problem%.%# Here %-G\\s%# ignores all lines that contains zero or more whitespaces. This ...


3

First thing I notice is that you have quotes in there. When using set everything after the = symbol is set to the value. Since errorformat has spaces and backslashes my preferred way to set it is with let and single-quoted strings, then string concatenation so I can break it up into more easily parsed lines. let &errorformat = \ '%*[^"]"%f"%*\D%l: ...


3

As Tumbler41 notes, isfname has to be turned on: If "%f" is followed by a '%' or a backslash, it will look for a sequence of 'isfname' characters. I had no luck inserting a % (%: is an invalid format), but I succeeded with a backslash. This requires a second backslash to escape the first. :set efm=%f\\:%l:\ % Then set efm shows the single backslash: ...


2

Disclaimer: I have never used errorformat before. Edit: Deleted pointless stuff that was a mis-understanding of the question. One other note. Earlier in the help doc it states: If "%f" is followed by a '%' or a backslash, it will look for a sequence of 'isfname' characters. Since yours doesn't, maybe that's why it can match a space? As @JigglyNaga ...


2

I'm not aware of any built-in mechanism of jumping to the location of an error in the error log. However, the default behaviour of errorformat is to include all of the makeprg output, so context can be seen in the quickfix window itself. The errorformat described in :help errorformat-LaTeX includes a number of patterns specifically intended to hide ...


2

As suggested by CrashNeb, %\\@= means \\@= as in regexp, which does a lookup ahead without actually consuming the characters. %[%^\ ], is [^\ ] (don't match \ or ) but escaped ([ and ^ needs to be escaped using %. So, %Z%[%^\ ]%\\@=%m means if the line doesn't start with a space or \, end the multiline (%Z) errors and use THE FULL LINE as a the message. ...


2

The issue is that the text you want to see in the message field of the quickfix list is disconnected in the original output: error: cannot format /home/user/repo/src/file1.py: Cannot parse: 2:5: some source code here ^^^^^^^^^^^^^ ^^^^^^^^^^^^ ^^^^^^^^^^^^^^^^^^^^^ Try to filter the errors first, with some script, ...


2

After going through other options, I realised that the default of quickfix is to capture all the output and use %- prefix to skip any lines after modifying the errorformat to CompilerSet errorformat=%.%#\ at\ %.%#(%f:%l:%c),%-G%.%# it worked. But this worked only in vanilla vim - compiler,make combo. I was using this as part of vim-dispatch and neo-vim ...


1

Try to change your errorformat to setlocal efm=%E%f:%l:%c:,%E%f:%l:,%C,%C%p%*[0123456789^],%ZError:\ %m,%C%.%# the difference is in separator between LINE and COLUMN. You have %l.%c, but looks like it should be %l:%c there are some problems with autocommands we cannot see from your example (but vim error clearly states it) if you do only set efm=..., set ...


1

It has nothing to do with Vim, as it's your make utility who sets output order. For GNU make read the manual.


1

After all I solved this problem using sed linux utilit. My solution: some-cli | sed "s/\x1b\[[0-9;]*m//g" | some-errorformat-vim-tool where sed "s/\x1b\[[0-9;]*m//g" remove all ansi-codes. This answer helped my: Can Vim interpret terminal color escape codes?


1

Afaik 'efm' of vim cannot handle this situation, i.e. %l matches only a sequence of digits with no spaces or linebreaks between the digits. Vim help discusses in more detail a possible value of'efm' for LaTeX but does not answer this question: :help errorformat-LaTeX Maybe you can ask this on the issue tracker of vim or the vim_dev mailing list to get an ...


1

set errorformat=[%t%*\\a]\ %f(%l):\ %m The pattern \a\+, is equivalent to %*\\a according to :h errorformat. However you may want to look to see if Vim already supports your compiler of choice. Do :compiler then tab complete or use <c-d> to get a list of known compilers.


1

I was able to eliminate the escape codes by changing the -fdiagnostics-color option in gcc. So this answers my first question (the escape codes in vim's make output were caused by a gcc option that colorizes its output, and had nothing to do with vim). I (mostly) answered my second question too. I was using this errorformat: set errorformat =%E%f:%l:%c:\ %...


1

You're asking to set up a search from the quickfix which as far as I know isn't possible via errorformat. However you could write a function to do it and then map that function to a keymap or a command or something. E.g. function JumpToLinkerError() let l:matches = matchlist(getline('.'), '^[^:]*.o:\([^:]*\):.*' ...


Only top voted, non community-wiki answers of a minimum length are eligible