New answers tagged

3

I think you might be misunderstanding how the 'fileformats' (plural) setting is used. This setting is a global list of file formats that Vim tries when opening any file in order to see which matches the format of the file. When it has detected the format, Vim sets the per-file 'fileformat' (singular) option for that individual file. If you are setting '...


0

As being said in comment by @ChristianBrabandt, tab needs 2 characters. Note that SPACE should be escaped when you do it in set, like this \: set listchars=tab:⭲\ ,eol:⮠,trail:· Check :h set-args: See |option-backslash| for using white space and backslashes in {value}. Alternatively, you can use let with &listchars (see :h :let-&)...


Top 50 recent answers are included