4

Thanks for the answer by Lngo. I've my answer posted bellow. I just put these in my ~/.vimrc file: "alphsubs ---------------------- {{{ execute "digraphs ks " . 0x2096 execute "digraphs as " . 0x2090 execute "digraphs es " . 0x2091 execute "digraphs hs " . 0x2095 execute "digraphs is " . 0x1D62 execute "...


4

You can use the :digraphs command to get a list of all defined digraphs. This isn't very easy to search, but we can use :redir to store it to a file: :redir all_digraphs :digraphs :redir END :e all_digraphs And we can now search the file: /<C-v>u271d which gives us: E385: search hit BOTTOM without match for: ✝ which confirms that this characters ...


3

There is no such digraph defined by default. You can review available digraphs at :help digraph-table. The listing includes hex and decimal values as well as the name of the character, so you can easily search for an entry, for instance with :help digraph-table|/0x271d or :help digraph-table|/CROSS. The closest ones I see by value are ✓ OK 2713 10003 ...


3

If there are literally only ten, then a simple, albeit inelegant, solution would be to leave 'digraph' switched off and just hard code the desired behaviour with ten insert mode mappings, e.g.: :inoremap e<BS>' é :inoremap i<BS>: ï It's not a perfect solution, because it results in slightly delayed/odd redraw while you are halfway through ...


3

First off, this answer suggests that there are no unicode subscript letters for all latin characters. However you can still get some of them (a list is provided by several answers in the linked answer) by using :digraphs with argumenst, e.g. :digraphs as 8336 where 8336 is the unicode encoding of the "LATIN SUBSCRIPT SMALL LETTER A" written in decimal. ...


2

I tried this on my linux box via putty and via cygwin, both seemed to work as expected for me. I'm wondering if perhaps your putty is actually not configured for UTF-8; I know for example ncurses apps with line drawing characters are affected by the putty translation setting. Try right-clicking on your putty title bar, go to "Change Settings...", then under ...


2

It will work only for (some of) the Vim 'special keys', literally - see :h ins-special-special. E.g. <C-K><Up>. Tab is not in that list. In addition, your terminal may not pass all key combos to Vim. For example, <S-Space> is there the same as <Space>, so it won't work (unlike in GVim). Long story short, your options seems limited, ...


2

I made the unicode plugin that helps with finding digraphs. You can use the command :Digraphs cross to search for a digraph whose name contains cross. Or when on the char, issue the command :Unicodename and it will output the digraph for that char. There are other similar commands as well, so check the help.


2

The origin of the problem was that tmux was consuming the C-k keypress. I had blindly followed the instructions that came along with the vim-tmux-navigator plugin at the time I installed it, which recommended using the following line in .tmux.conf to identify whether or not vim was running: is_vim='echo "#{pane_current_command}" | grep -iqE "(^|\/)g?(view|n?...


1

As @D.BenKnoble and @statox have mentioned, this sounds like you have the 'digraph' option set in Neovim but not in Vim. Running :set nodigraph in a running instance of Neovim should fix the problem, and you can run :verbose set digraph? to find out what part of your configuration is setting this option so you can resolve the issue properly. See :help ...


1

If the digraph has a code point (usually found by a web search for unicode <character description>), you can just use <c-v>u#### to directly enter it. For example <c-v>u00e4 yields ä. This does assume your editor can interpret the UTF-8 encoding.


1

You can make it output a ¨ by putting 168 as the output symbol, i.e. with, say, :dig um 168, but not use inside a digraph itself (:dig a\168 228 still wont make <c-k>a¨ output ä.) Even the predefined digraphs use : instead; e.g. <c-k>a: give you ä.


Only top voted, non community-wiki answers of a minimum length are eligible