4

Google for vim to find their homepage. You find http://www.vim.org . Look on their homepage, where is their upstream source. If you have luck, they are on the github. On the "Download" section, they show many of their upstreams, first is the github one. They say, git clone https://github.com/vim/vim.git is the clone command what you want, however you want ...


4

My understanding is that the makeprg setting is primarily used to change the actual make/build program and in your case the program isn't changing...it's always 'make'. Since :make accepts arguments I suggest leaving 'makeprg' alone and passing your build command args to :make in the two mappings... noremap <F4> :make -f ~/makefile1 %<<CR> ...


3

This happens because a 'shellpipe' of the default of > (which is the default on Windows) doesn't really work on Powershell. It seems to have it produce a file that uses UTF-16 encoding and then NeoVim has trouble parsing the Unicode BOM character at the beginning of it. The 'shellredir' setting gives us a good clue of how to solve it... So just setting '...


3

You can find the instructions to build Vim on windows in the source file src/INSTALLpc.txt. More specifically in the section 8. Building with Python3 support you can read: 8. Building with Python3 support ================================ For building with MSVC 2008 the "Windows Installer" from www.python.org works fine. Python 3.6 is recommended. When ...


2

Vim features are not completely orthogonal, so not all of them are available as individual flags to enable/disable. If you want a minimal build of Vim, you can use --with-features=tiny. I believe this will disable the statusline feature as well, together with many other features disabled to produce a minimal build. This setting is already available in the ...


2

While +ipv6 is indeed an existing and valid Vim feature, it's not directly available for enabling or disabling via an --enable-* or --disable-* argument to ./configure. The way this was implemented, the option gets enabled based on the check for the system building Vim having support for the libraries needed to implement the feature. While there's no ...


2

The answer came down to a local install of glib-2 which, because it was installed to /usr/local/lib was superseding the glib-2 installed in /lib64. As an example, a function named g_task_set_return_on_cancel which is part of glib v2.36 and later, was not found. I'd installed 2.32 (for reasons which I have presently forgotten) and it was superseding the ...


2

Compile Vim via MacPorts Macports provides currently a more granular installation approach for vim than homebrew: It offers the feature variants tiny, small, big, and huge. You can add specifically the interfaces for ruby, perl, lua, python. For all variants see https://ports.macports.org/port/vim/summary However, you can add this functionality to the ...


2

Find your dynamic python lib, for example libpython3.6m.so.1.0. Then put it in your .vimrc like this: set pythonthreedll=/location/of/your/python/lib/libpython3.6m.so.1.0 Of course, change the version of the library name accordingly.


2

The problem was solved. The :python3 or :pythonx (:py3 or :pyx) should be used instead of the simple :python. See :h python3 and :h pythonx. So, :py3 print("hello") gives hello as expected. Also, to see what version of Python is being used, do: :pyx import sys :pyx print(sys.version) in my case it gives 3.6.9 (default, Nov 7 2019, 10:44:02) [GCC 8.3....


1

When you run your code with :make, the result is put into the quickfix list, you can open it with :cope See help :make See help quickfix You can also make your own command that show immediatelly your results: command! -nargs=* Make :make <args> | cope You just have to use :Make instead of :make to run your programm and be prompted to the quickfix list....


1

I recommend using the vimtex plugin. It allows opening zathura as a PDF viewer after compiling in one step. Also it has continuous mode, meaning that you will be able to see automatically compiled changes immediately in the running zathura instance.


1

Following instruction here and install appropriate package and set appropriate flags: https://github.com/LucHermitte/vim-build-tools-wrapper/blob/master/doc/make_run.md#mono-file-projects We can just do :make %< and !./ %< to build and compile cpp file


1

I somehow figured out what was going on. The problem was due to a trailing whitespace at the very end of the keybinding. That was acting as extra key to escape back from the terminal. Removing it resolved the issue.


1

Check :help if-pyth: you need to use :python3.


1

To get a one column list of Vim's compile options you could use this script: 1 #! /bin/bash 2 3 splitme() 4 { 5 while read -r line || [[ -n "$line" ]]; do 6 line4=$(echo $line | perl -p -e 's/ +/ /g') 7 for one in $line4 8 do 9 echo $one 10 done 11 done 12 } 13 14 vim --version | grep '^[+-]' | splitme | sort --key=1.2 ...


1

It's all in :h :version and :h +feature-list ... The first column shows the smallest version in which they are included: T tiny (always) S small N normal B big H huge m manually enabled or depends on other features (none) system dependent ... ... N *+startuptime* |--startuptime| argument It requires version no less ...


1

I worked around this problem by using the compile switch: --disable-netbeans However, obviously it is just a workaround and the test failure will be a problem for anyone that wants to use netbeans with compiled vim.


1

To configure the build the script configure in the root of the source tree is used. This script supports the option --help. It will print the available options with explanation. So: cd to the root of the source tree and run: $ ./configure --help `configure' configures this package to adapt to many kinds of systems. Usage: auto/configure [OPTION]... [VAR=...


1

This is really strange. Basically: in my compiled vims, as long as I run py import vim, vim becomes defined thereafter and everything works. So I can probably just add this statement in my vimrc and move on with my life. There must be some undocumented compile or config flag that makes this happen automatically by default or something.


1

I assume that you don't have the needed libraries installed on your system to build a gui. If you read the file src/INSTALL it explains the different --enable-gui options. For example for me I could run ./configure --enable-gui=kde && make just fine but the resulting vim did not have a gui. When I checked ./configure --enable-gui=kde | grep gui I ...


1

As @muru has suggested, I will post the solution here.. The situation happened, when I was trying to debug a issue related to a plugin. It seemed to work for a colleague, but not for me. So one of the hypothesis was that it was because of the differing versions of VIM. Because the VIM version (8.0.1430) was compiled from source, I had the exact SHA id of ...


Only top voted, non community-wiki answers of a minimum length are eligible