Questions tagged [softtabstop]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1
vote
1answer
59 views

Why is my setting of `set softtabstop` in vimrc being clobbered when editing python files?

I am using vim 8.0.1763 on CentOS 8.1. Here is my ~/.vimrc " Cool vim plugins : http://vimawesome.com/plugin/fugitive-vim set number filetype plugin on " https://stackoverflow.com/questions/...
1
vote
0answers
26 views

Can't redefine tabstop, softtabstop and softwidth after syntax detection

I've a vim: VIM - Vi IMproved 8.2 (2019 Dec 12, собрано Apr 8 2020 14:10:43) and I tried to redefine tabstop, softtabstop and softwidth values for a file after detection of its syntax. I.e. I have a ...
0
votes
1answer
176 views

Neovim keeps reverting shiftwidth size after `after/ftplugin`

I like to code with 4 spaces as a tab. I added this to after/ftplugin/sass.vim: echom "before sass file settings" set shiftwidth=4 " <---- Problem setting, keeps changing back to 2 ...
1
vote
1answer
255 views

Setting softtabstop for Python

I am following this guide from realpython.com to fine tune vim for Python development. It suggests the following section in the .vimrc file: au BufNewFile,BufRead *.py \ set tabstop=4 \ set ...
2
votes
1answer
152 views

Moved from vim to neovim and now <BS> deletes 4 spaces at a time, instead of 1 as I'm used to. How to fix?

I've used vim for ages and am really used to inserting four spaces by hitting tab, but then being deleting them one by one. Now that I've switched to neovim this has changed to it inserting four ...
2
votes
1answer
414 views

tabstop, softtabstop, shiftwidth - confused

I read through Vim documentation, blogs and SO questions on tabstop, softtabstop, shiftwidth, expandtab. I understood their purpose (may be not), but for all of the following setting, hitting tab key ...
0
votes
1answer
117 views

softtabstop not working [closed]

I have a problem with my softtabstop option. For some reason when I put this line in my .vimrc set softtabstop=4 it does nothing. However if I do it as a command :set softtabstop=4 it does work ...