Questions tagged [plugin-vundle]

Questions about the plugin manager Vundle.

Filter by
Sorted by
Tagged with
1
vote
1answer
72 views

Powerline font not working with airline in (g)vim on Windows 10

I'm trying to set up patched fonts from powerline/fonts with airline in gvim under Windows 10 64 bit. As you can see from the screenshot here: the characters from the font do show up, but the airline ...
0
votes
0answers
49 views

Problems installing Vundle in fresh install of Vim

I, I'm trying to to install vim to use as a Python IDE on arch. I was using this tutorial to do it, but ran into some troubles. When I tried to open vim I got the following error messages: https://...
1
vote
1answer
69 views

Error detected during LaTeX-Suite-aka-Vim-LaTeX plugin update with Vundle

When updating vundle-managed plugins with: :PluginUpdate in buffer, I get the following error message: Error detected while processing ~/.vim/bundle/LaTeX-Suite-aka-Vim-LaTeX/plugin/remoteOpen.vim: ...
0
votes
1answer
357 views

Vundle not instaling Plugins / Ignoring

I installed Vundle via git clone https://github.com/VundleVim/Vundle.vim.git ~/.vim/bundle/Vundle.vim, and have my .vimrc as: set nocompatible " be iMproved, required filetype off ...
3
votes
2answers
303 views

Common vimrc config for unix and windows

I'm looking for a way to make a single configuration file both for windows platform and for unix one. So for now i have two configs .vimrc for unix and _vimrc for windows platform and the only ...
1
vote
2answers
2k views

Cannot remove a plugin with Vundle

Other than deleting the plugin directory in /bundle/ I have not been able to successfully uninstall a plugin. I found this issue and have tried removing the plugin from my vimrc, running :...
2
votes
1answer
530 views

Installing Vundle: “fatal: could not create leading directories”

Following the instructions on the Vundle GitHub page, entering git clone https://github.com/VundleVim/Vundle.vim.git ~/.vim/bundle/Vundle.vim in terminal on MacOS gives fatal: could not create ...
1
vote
1answer
609 views

can't install some plugins with vundle

Here is the vundle part of my vimrc file(I'm omitting the rest to have a minimal q, ask me to put the rest if you think it's needed): set nocompatible " required ...
2
votes
1answer
2k views

How to install fzf.vim with Vundle?

I use Vundle to manage my vim plugins. However I just came across fzf, and its installation instructions require that I use vim-plug. How do I make this happen? Wouldn't there be a conflict between ...
0
votes
1answer
302 views

Setting up an opt-in system-wide vim config

I'm working on a Python 3.6 project (with several friends that are new to Unix) using vim on a debian-based system I own. I'm wondering if there's a way I can setup a system-wide vim configuration ...
1
vote
1answer
1k views

How to use vundle for vim installed from AUR

I'm in a process of completely switching to vim for my development purposes. In order to make it more IDE-like I want to install a couple of plugins and I decided to use vundle as a plugin manager. ...
1
vote
1answer
224 views

Stopping :PluginInstall safely

Is there a way to stop PluginInstall while it's running. The typical scenario in which I need this is when installing a new plugin (basically one line added to the .vimrc), and once PluginInstall ...
0
votes
1answer
291 views

What is wrong with my DoxygenToolkit.vim?

My DoxygenToolkit.vim was installed this way. 1.To open `Root Terminal` with root password 2.mkdir -p /usr/share/vim/vim74/bundle 3.git clone https://github.com/gmarik/Vundle.vim.git /usr/share/...
0
votes
1answer
719 views

Vundle doesn't load the theme

This is my .vimrc located under $HOME/.vimrc. I've installed Vundle. set nocompatible " be iMproved, required filetype off " required " set the runtime path to include ...
0
votes
3answers
1k views

How do you add a local plugin in Vundle on Windows?

I am using Vundle on Windows gVim. I have a plugin that I am writing myself called hotdogstand that is stored in my local filesystem at vimfiles\hotdogstand, and it is not tied to a Github repository. ...
1
vote
3answers
337 views

Vundle load plugins while still in .vimrc

I'm trying to create my first own .vimrc file. I'm having some trouble when trying to load plugins with Vundle. For example, I want to use vim-airline, so I have (in the correct place I believe) in my ...
1
vote
0answers
399 views

Solarized colorscheme is not displayed correctly (cursorline and relativenumber column)

It worked fine on my home pc, but it messes up colors on my working machine. Here is my .vimrc: set nocompatible filetype off set rtp+=~/.vim/bundle/Vundle.vim call vundle#begin() Plugin 'VundleVim/...
6
votes
2answers
39k views

How to install YouCompleteMe with Clang completer offline?

I have installed YouCompleteMe with Clang completer in OS X 10.10.4, and in my new OS X 10.11.4 I want to reinstall it. The previous installation process downloaded about 140MB at very low speed. I ...
4
votes
1answer
194 views

Vundle won't install plugins due to an error about AppData/Local/Temp

I am on Windows 10. I just installed Vundle and now I am trying to run the PluginInstall command. However, I am getting errors saying it can't open a file in AppData/Local/Temp. This does occur on all ...
23
votes
1answer
37k views

How do I configure the Vim airline plugin to look like its own project screenshot?

I am trying to get the vim-airline up and running. I have required it via vundle in my ~./vimrc: Plugin 'bling/vim-airline' I have installed it and expected my Vim to look like the screenshot on ...
2
votes
1answer
608 views

Vundle/vim can't see changes in .vimrc

I'm enforcing some strange behaviour of Vundle plugin. Basically, from time to time, i'm not able to install new plugins using :PluginInstall because Vundle can't see the new Plugin entries in my ....
9
votes
2answers
6k views

vundle “filetype plugin indent on” messes with tabwidth

I installed vundle yesterday and since I did, the tabwidth I configured in my vimrc is ignored and set back to 4 instead of 2. I found out that the following line after the vundle paragraph is ...
4
votes
1answer
1k views

Error while processing .vimrc in vagrant when I run `git commit -v`

I am working on a CentOs machine. Vim works fine. But when I git commit -v It seems that something is wrong: [vagrant@localhost dotfiles]$ git add . [vagrant@localhost dotfiles]$ git commit -v Error ...
-1
votes
1answer
6k views

cannot install NerdTree pluging with Vundle [closed]

I recently start using Vundle as plugin manager. It nicely installed all my plugins, except NerdTree. when trying to install Plugin 'scroolosse/nerdTree' vundle tries to connect to github, thru ...
2
votes
1answer
428 views

Vim - Dotfiles - Vundle not recognized

So, I decided to manage my vimfiles (not dotfiles yet :P). I copied .vim and .vimrc inside a dotfiles folder (and removed the dot from the filenames). I initialized git dir and pushed it to Github. ...
2
votes
1answer
3k views

vim doesn't find jedi, even though it's right there!

I have installed jedi-vim using Vundle, adding this line to my .vimrc and running :PluginInstall. Plugin 'davidhalter/jedi-vim' The jedi-vim docs say I can install jedi using git submodule update --...
15
votes
2answers
3k views

What makes a plugin Vundle compatible and are other plugin managers interchangeable?

For a long time now I've been using Vundle to manage my vim plugins. As best I can make out this basically just organizes plugins in an isolated directory structure and keeps track of updating them ...