Questions tagged [plugin-ale]

The tag has no usage guidance.

8 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
4
votes
0answers
57 views

Can vim-ale emit an error when it fails to parse compiler output?

Ale does not always indicate an error when compilation fails. AFAICT, the reason is that ALE's parser can't find a reference to the current file in the compiler's error messages. This is because ...
1
vote
0answers
63 views

vim w0rp/ale plugin stops working out of the blue

Long time reader, first time poster. I'm having an issue with ALE (asynchronous lint engine) -- be aware that I'm a second year student and relatively new to programming. I really like this plugin. ...
1
vote
0answers
136 views

Jinja html templates formatting with ALE and Prettier in Vim

I am using NVIM v0.3.2-208-g2841e89 on Ubuntu 16.04 LTS and using ALE as my Linting Engine plugin. I am having issue with formatting for jinja template html files with prettier. The html files which ...
1
vote
0answers
608 views

How to setup ALE with clang?

I'm trying to setup ALE with clang but apparently clang has no idea about my source files - it cannot find included files for a start. How can I tell ALE/clang were are all my sources? If you ...
1
vote
1answer
341 views

Use flake8 for Cython with w0rp/ale

I'm using flake8 to check my code with ale plugin. I found a way to make it work with Python 3, but it seems it does not recognize Cython file (.pyx) even if we set as follows. let g:ale_linters = { \...
1
vote
0answers
68 views

Lint when finished writing a line

How could I have ale lint when finishing typing a line? Maybe on new line? let g:ale_lint_on_text_changed = 'never' autocmd NewLine ALELint
0
votes
0answers
25 views

Autofix a single line in ALE

When prettier tells me to take one line with a whole object and put every property on a new line, I want a key to autofix that. I know prettier has things that can be auto-fixed, but I have no idea ...
0
votes
0answers
72 views

ALE - how to configure warnings to appear in the command line?

I'm trying to workout whether this is an issue with my ALE configuration, or it's some kind of bug with the linter. Basically I'm using tsserver and prettier for Typescript with ALE. Both error and ...