Questions tagged [path]

Questions about the usage of the Vim's path variable. this variable lists the directories which will be searched with commands like `gf`, [f, ]f, ^Wf, `:find`, `:sfind`, `:tabfind`

8 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3 votes
0 answers

How to keep lcd from affecting other windows?

I usually have one tab containing the code I am working on, and another containing vimwiki. I mostly use neovim. For the code I prefer the working directory sticking to the project root. For vimwiki ...
bdecaf's user avatar
  • 279
2 votes
0 answers

syntastic not working on macvim, but works perfectly fine on the terminal

I have an issue where in MacVim, I don't get any syntastic/eslint related functionality. When I run !which eslint in macvim, I get "eslint not found" - eslint is definitely installed. If I run !...
filype's user avatar
  • 283
2 votes
0 answers

The $path used by ":!start cmd" is different from my system $path in windows

So I do a lot of python work in GVim on Windows 7, and I'm running into an annoying roadblock. This might be more of a Windows question, but it's happening in Vim, so ... I have this in my python.vim ...
Tyler Fox's user avatar
1 vote
0 answers

Open file with path over 260 signs length in WIndows

Is there any way to open file with Gvim under Windows 10 from path over 260 signs length with out mapping the path to network drive?
gradzikb's user avatar
1 vote
0 answers

How to autocomplete path using alias root?

I'm working on frontend project, we're using root alias, like: import from '~/src/components/button'; instead of: import from '../../../../../components/button'; But when I try to import from ~/, my ...
Lai32290's user avatar
  • 245
1 vote
0 answers

Why is filetype not set after :find from autocmd?

Objective I want vi file to act like :find file if file doesn't exist. That is, I want to be able to edit a file by name, without giving a path to the file, from the command line: mkdir -p a/b/c ...
aghast's user avatar
  • 217
0 votes
1 answer

Simple way to go to definitions

I use this simple approach to jump to definitions in C++, which works fine for me. In my vimrc: autocmd BufRead,BufNewFile *.c,*.cpp,*.cc set path+=/Library/Developer/CommandLineTools/usr/include/c++/...
ranemirusG's user avatar
0 votes
1 answer

Setting path in init.lua

One of my packages needs me to set up the PATH and one variable. In my vimscript code I had: let $PATH.=':/usr/lib64/openjdk-11/bin/' let $MYVIMRC='/home/luis/.config/nvim/init.vim' But I can't ...
lf_araujo's user avatar
  • 113