Questions tagged [installing]

Questions about the installation procedure of Vim and potential errors encountered in the process.

Filter by
Sorted by
Tagged with
56
votes
3answers
40k views

How can I get a newer version of Vim on Ubuntu?

Ubuntu's packages can be pretty old, but for some desktop programs (like Vim) I'd much rather have the latest version, as newer versions often fix various bugs. How can I get a reasonably recent Vim ...
33
votes
10answers
74k views

How to enable +python feature in vim

I want to install a vim plugin, this plugin needs a +python feature, so when I open vim and type :version it displays -python. How can I make it enable?. Thanks.
28
votes
2answers
10k views

Why is Vim for Debian compiled without clipboard?

I'm curious as to why the default Debian package for vim (the one you normally get by sudo apt-get install vim) isn't compiled with clipboard support? Neither the regular -clipboard or -Xterm-...
25
votes
7answers
37k views

Vim 8.0 Python support

I'm trying to upgrade my Vim installation to version 8.0, but it doesn't support both Python and Python 3 as the below image. (PS: Because of this problem, I cannot use the YCM (YouCompleteMe) plugin ...
21
votes
4answers
21k views

How can I install 64-bit Vim on Windows?

Vim's Downloads page says the 64-bit version is discontinued: Win64 The 32-bit version of Vim runs fine on 64-bit windows. There was a 64-bit binary, but it wasn't used much and maintenance ...
20
votes
1answer
7k views

How do I get +clipboard support in Fedora 20?

It seems to me that neither "+p nor "*p works for me. How can I know if my Vim is installed and set up properly to make them available? And if it's not set up, what can I do to set it up? I'm running ...
14
votes
5answers
14k views

how to install vim with python support for debian strech

I installed debian strech two days ago. I installed vim and configured some plugins. I always encountered the following error while opening any file: vim app.py Error detected while processing /home/...
13
votes
1answer
12k views

Vim compiled with python3 but has('python') returns 0

I just followed these instructions to compile vim with python 3: https://github.com/Valloric/YouCompleteMe/wiki/Building-Vim-from-source After the install I checked to see if I have python3: vim --...
11
votes
3answers
14k views

Is there a difference between “sudo apt-get vim” and “./configure --with-features=huge”?

I'd like to install VIM via apt-get, but I'm not sure if I get all of its features. Is there a difference between this, and compiling it from source?
8
votes
2answers
4k views

How can I build vim with just python 3 support?

I'm on Arch, and recently the vim-python3 and gvim-python3 packages were removed, so I'm working on building vim from source such that the :python command will act as python3. Specifically, I'm doing ...
7
votes
2answers
7k views

How to install stable version of neovim on Ubuntu 18.04

No matter how I do it, I seem to get the nightly or the 0.2.2 version. How do I install the stable version of Neovim. I have too many issues in the nightly. I used sudo apt install neovim and when I ...
7
votes
1answer
11k views

How to build vim from sources with GUI support?

I am trying to build vim from source, especially gvim, to get some of the bug fixes that have been plaguing me in the office repository. I can compile vim fine but gvim is not being generated due to ...
7
votes
1answer
156 views

How can I automate checking for new Vim releases on Windows?

Following up my earlier question (How can I install 64-bit Vim on Windows?), I'd like to automate updating Vim. On Linux, I let the package manager and its frontends take care of checking for updates ...
7
votes
1answer
4k views

Trying to compile vim with python 3.6. Where is my config directory?

I'm a bit of a noob when it comes to Linux, only started using it recently. However, I am trying to compile vim with python because I am using latex live preview and it needs a python compiled vim ...
6
votes
2answers
9k views

Can I still use console vim if I install a GUI version?

If I purge my existing vim-full installation and install a GUI version like vim-gnome or vim-gtk, can I still use it in the text mode I am familiar with? What if I am using it from a terminal via SSH?...
5
votes
1answer
4k views

Compiling vim from source just enabling clipboard

I have a Debian 7.0 with gnome, and I am fully satisfied with the standard vim version installed on it, except for the lack of +clipboard and/or +xterm_clipboard. I got the sources using mercurial, ...
5
votes
1answer
932 views

Trying to install pathogen, but where?

I make a .vim directory in my home directory. I then made an autoload directory and a bundle directory. I added the pathogen.vim file to the autoload directory. I then added execute pathogen#infect() ...
4
votes
2answers
501 views

Install vim features

I have installed a tiny vim version without the clipboard feature. Can I load this feature for the current version or do I have to install another version of vim? $ vi --version VIM - Vi IMproved 7.4 ...
4
votes
0answers
669 views

How to create an Edit-with-Vim context menu entry for Vim 8.1 on Windows 10

The Explorer context menu entry does not get created by the installer. Windows 10 Pro v1803 (64-bit). What I have already tried: Installed Vim 8.1 using the stock Windows installer https://ftp.nluug....
3
votes
1answer
4k views

Unable to install most recent gvim 8.1 on Ubuntu

On Ubuntu, when I do vim --version in the terminal I get: VIM - Vi IMproved 8.1 (2018 May 18, compiled Jan 6 2019 14:05:44) Included patches: 1-699 However, when I do gvim --version I get: VIM - ...
3
votes
1answer
2k views

How to turn off completion (enabled by default in Arch)?

When I install vim from repository on Arch Linux, it has a completion feature that I don't like. What is it called and how do I turn it off? (It is active even with a blank .vimrc.) I would rather get ...
3
votes
1answer
5k views

How do I install Neovim with GUI and msgpack support in Ubuntu?

I would like to get Neovim because of its msgpack API and clear roadmap of development, but it is not in Ubuntu 16.04's repositories. Command 'gvim' from package 'vim' (main) Command 'gvim' from ...
3
votes
2answers
349 views

How to ensure files are copied to VIMRUNTIMEDIR when building Vim 8.1 from source and specifying a prefix?

I compiled vim 8.1 for Ubuntu 16.04 x64, from source, by following Valloric's excellent guide on the subject. Although that guide is for an older version, it was really simple to check out the correct ...
3
votes
1answer
1k views

How to uninstall NeoBundle in OS X?

I was trying to revamp the vim editor so I installed NeoBundle but I didn't like it. How can I uninstall it completely? I followed the installation instructions given in the readme: $ curl https://...
3
votes
2answers
2k views

How to update vim on centos7?

By default, the version of vim on centos7 is 7.4. I want to update it to vim 8. There are some questions with 'https://copr.fedorainfracloud.org/coprs/mcepl/vim8/repo/epel-7/mcepl-vim8-epel-7.repo -o /...
3
votes
1answer
95 views

Is there a source for pre-built patched Win32/Win64 vims?

Turns out my problem with this answer is that I need patch 7.4.143. I can't find any download on vim.org for a Windows patched-vim installer. Is there an official distribution of patched vim 7.4 for ...
3
votes
1answer
997 views

Vim 8 built locally with custom prefix — doesn't find tutor right off the bat

I tried to install vim from source. I do not have sudo rights. So, i cloned the last revision from github, and configured as follows: ./configure \ --with-features=huge ...
2
votes
1answer
351 views

infinite loop when compiling vim from source code

I use two servers, both using redhat, and I need to most of work on server, not on my PC. My sysadmin did not update vim for a very long time, like, system's default vim version is 6.x, which is ...
2
votes
1answer
793 views

How do you install 64-bit version of vim 8.2 from gvim82.exe?

The download page clearly states that the gvim82.exe installer has an option to choose which version of vim to install, a 32- or a 64-bit. I cannot find this option. The installed vim is 32-bit, while ...
2
votes
1answer
58 views

:GhostInstall does not work

Note: I am fairly new to NeoVim. So far I have installed plugins by simply unzipping the plug-in master folder into the directory /usr/share/nvim/runtime/plugin. In case there is no master folder I ...
2
votes
2answers
2k views

Compiling Vim with python3 showing E370: Could not load library libpython3.7m.a

I have been trying to compile Vim with python3 on my Mac for many hours, as a result, it looks fine now, as the following: VIM - Vi IMproved 8.1 (2018 May 18, compiled Dec 9 2018 00:37:54) macOS ...
2
votes
2answers
4k views

Unable to uninstall VIM installed from source

I installed VIM by compiling from source a while back following the instructions here. At that time, for some reason, I didn't use checkinstall, as a result I can't uninstall it using sudo apt-get ...
1
vote
2answers
682 views

How do I enable profile in vim?

I learned about using :profile here, so I just tried to install vim with profiling enabled. I tried this: ./configure --prefix=/home/username --with-features=profile But in the output from ...
1
vote
1answer
108 views

Error when installing Vim

I cloned Vim from the GitHub repo and then run ./configure --with-features=huge \ --enable-multibyte \ --enable-rubyinterp=yes \ --enable-python3interp=yes \ ...
1
vote
1answer
313 views

vim process memory consumption increase with time

Folks, I am running my vim-8.1.1 compiled in my debian stretch system. The vim process slowly eats up to 40% of my system memory in about 4-5hours. No big files opened. ~4 tabs opened (each with 2 ...
1
vote
1answer
701 views

How can I fix my dependencies installing vim

I had vim working for a while and uninstalled it for no good reason. To reinstall it I gave the following commands: sudo apt-get update I get warnings that the respository deadsnakes/ppa and pycharm/...
1
vote
1answer
287 views

Enabling or installing blowfish2 capabilities on VIM 7.4.52

I've read that blowfish2 encryption is available on VIM 7.4.399. For some reason, my version—7.4.52—does not have blowfish2 capabilities (it has blowfish capabilities, though). I used sudo apt ...
1
vote
0answers
592 views

Vim shows error when running python3

OS: Ubuntu 18.04 First, I ran apt-get install python3-dev ruby-dev Then, I installed vim using the instructions in the website, using make distclean, make and make install (This was like the tenth ...
1
vote
2answers
2k views

How to install Vim 8.1 Silently on Windows?

I am trying to install gvim81.exe on multiple computers. The /s switch isn't working and /? doesn't give any results. Does anyone know how to silently install this version?
1
vote
1answer
377 views

How to avoid dependency conflics when installing vim from source?

I run Ubuntu 14.04 and want to use YouCompleteMe with vim for python and c++ code completion. YouCompleteMe requires vim 7.4.143+, which is higher than what I get with apt-get, so I follow this ...
0
votes
3answers
14k views

Where is my vim installed?

My vim was installed on debian8 with the apt-get command. apt-get install vim $ find / -name 'autoload' /usr/share/vim/vim74/autoload $ find / -name '.vim' The above command can find nothing. $ ...
0
votes
1answer
1k views

unable to compile vim with perl support on linux

For some reason my Vim won't compile with perl support. Here are my configure options: ./configure \ --with-features=huge \ --enable-multibyte \ --enable-rubyinterp=yes \ --enable-...
0
votes
1answer
285 views

Why doesn't Vim recognize that I have Python installed?

I'm on the latest version of Arch Linux. The version of Vim from the Arch repos doesn't have python support, so I downloaded the source code and built it from that. I have checked, and Python support ...
0
votes
1answer
1k views

Vundle not instaling Plugins / Ignoring

I installed Vundle via git clone https://github.com/VundleVim/Vundle.vim.git ~/.vim/bundle/Vundle.vim, and have my .vimrc as: set nocompatible " be iMproved, required filetype off ...
0
votes
1answer
250 views

Which compile flag enables “balloonexpr”?

When loading a session file from another machine I get errors of the form E518: Unknown option: balloonexpr= Which is one of the more obscure features of Vim that I don’t seem to have compiled in. ...
0
votes
1answer
3k views

Python integration in Vim on Raspberry Pi

I am relatively new to programming, and I built a mobile computer with a Pi at its heart to learn on the go. Ideally, I would use Vim as my IDE for Python 3. However, every attempt at installation ...
0
votes
1answer
2k views

what is the installation size of vim?

How much space does vim take up in for example Ubuntu 18.04.1? I'm not sure how to check, I don't want to apt purge and then install again
0
votes
2answers
110 views

Installing a Vim package. syntax highlighting does not turn on

I want to use the nuweb.vim extension for syntax highlighting nuweb files. Long story short, nuweb files are basically a super-set of latex files. There is added syntax and markers to embed code-...
0
votes
1answer
183 views

How to compare two different Vim installs?

Basically, I want to compare which features were enabled when each installation of Vim was compiled. If there's also other significant differences between the two installations, besides their feature-...
0
votes
1answer
1k views

How to install a colorscheme with a plugin manager [duplicate]

I was wondering if someone could assist me in installing a color scheme for VIM? I literally have spent all day yesterday and this morning trying to figure it out. I am using a shell-client (ubuntu) ...