Questions tagged [cmdline]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
0answers
12 views

Change match highlights on CmdlineLeave

Vim uses two different highlight groups for matching patterns while searching in the command-line with / or :substitute for example. The incsearch group for the match under the cursor The search ...
0
votes
1answer
18 views

CmdlineEnter vs CmdwinEnter (In the context of changing Cmdline background color)

Firstly, Im using NeoVim (as you can tell by the winhighlight command). When entering the command line by pressing :, I change the command line window foreground/background. The following very ugly ...
4
votes
1answer
327 views

Where is the documentation for this ex command?

:1 jumps to the first line, :$ jumps to the last line, :+ jumps to the next line, etc. It seems to me that there is a default ex command which accepts a range and jumps to it: what's the name of ...
1
vote
0answers
59 views

Why does vim work if command file is double clicked, but not from DOS?

(Windows7-64bits-Vim8.1) I have a problem with getting the python in Vim to work. This problem is probably caused because I do not have admin access to the machine; I can't help that. In order to ...
0
votes
1answer
66 views

cmap macros not working as expected

I have been trying to make a macro to allow me to check in/out files via the vim command line. Currently what I have which "sort of" works is this: nmap :checkout :! cleartool checkout -nc % As you ...
1
vote
2answers
254 views

cmdline: how to expand `##` in-place?

In Ex mode, ## can be expanded to the files in the args list when files are expected, see :h cmdline-special In Ex commands, at places where a file name can be used, the following characters have a ...
1
vote
0answers
46 views

Incorrect formatting of file when calling nvim inside NodeJS script

I am formatting elixir files .ex with the help of a contributed plug-in for nvim like this on Windows: cmd> nvim.exe -i NONE -n -E +"norm gg=G" -cwq c:/file.ex This works fine when the command is ...
1
vote
1answer
158 views

How to disable expansion of percent sign('%') in cmdline and `:exec`?

Besides type in cmdline directly, I also use vnoremap <F2> :<c-u>exec join(getline("'<","'>"),"\n")<CR> nnoremap <F2> :exec getline(".")<CR> nnoremap <F3> :....