Linked Questions

1 vote
1 answer
96 views

Choices for pasting

In my local PC I use p in Vim command mode for pasting and it works fine and the :echo has('clipboard') returns 1. But, in the cluster I am working p in command mode, which just inserts a 0 instead of ...
Dimitris Tsiaousidis's user avatar
1 vote
0 answers
78 views

Vim only sometimes choosing to copy to system keyboard

I have the following situation. If I open a file in Vim, say by running vim myfile.tex, select something in visual mode, and do "+y, it is in the system clipboard as one would hope. If however I ...
jdc's user avatar
  • 141
24 votes
4 answers
6k views

I Have a Problem with Premature Yanking

If I've already yanked 37 lines, is there a way to send them to the clipboard without having to select them again? I need to move those yanked lines into a GUI application.
Lonnie Best's user avatar
-1 votes
1 answer
302 views

How to always paste to clipboard? [duplicate]

I am searching for an option to always paste to the system clipboard when using any kind of yank action, because I want to use Vim as the scrollback buffer for Kitty. I have already tried clipboard=...
neolith's user avatar
  • 133
0 votes
2 answers
768 views

"Copy" is greyed out in the Terminal menu after "Select All" in "VIM embedded in Terminal"; VIM copy does not work. How to copy the full file text?

I have set VIM as the default editor in the Terminal. I changed the ~/.bashrc: export VISUAL=vim export EDITOR="$VISUAL" You can also set the default editor only for git: git config --...
questionto42's user avatar
0 votes
1 answer
2k views

How to copy text to clipboard in visual mode? [duplicate]

I ran the following sequence of commands: V10j ⌘ c but it seems like this doesn't copy the ten lines to my clipboard. So how can I do this?
NeoZoom.lua's user avatar
  • 1,530
0 votes
0 answers
13 views

How to remap copy and pasting to keyboard [duplicate]

I'm trying to remap the current keybindings to make it simpler for yanking and pasting but it doesn't work. Some of my ~/.vimrc noremap <Leader>Y "*y noremap <Leader>P "*p ...
A.K.M. Adib's user avatar
1 vote
1 answer
117 views

Why cant i use `"+` in vim? [duplicate]

Previously, whenever I typed "+yy in vim, it yanked a line to the system clipboard. I reinstalled the OS again, and, when I try to do the same now the input disappears after entering +. Steps: I ...
Machine Yadav's user avatar
1 vote
0 answers
56 views

No + or * register on Linux (accessed via SSH from macOS)? [duplicate]

I am on Ubuntu 14.04.3 and Vim 8.2. I'm trying to figure out how to access either the * or + clipboard on Ubuntu but it seems like it doesn't exist? After doing "*yy and "+yy on lines of ...
David542's user avatar
  • 2,455
2 votes
0 answers
726 views

Copy all text in Vi and then paste it to another application on another system

I connect to Linux server via SSH using Putty terminal. I open a file with Vim and press ggVGy in order to select all text and copy it. But when I try to paste the copied text to Windows Notepad, it ...
kamokoba's user avatar
  • 121
10 votes
1 answer
21k views

how to yank from vim to system clipboard? [duplicate]

I'm using the latest version of vim 8.2.148 on the latest version of arch linux 5.5.6-arch1-1 with the latest version of Openbox window manager version 3.6.1. I have written a document in vim and ...
Kes's user avatar
  • 663
3 votes
1 answer
1k views

copy-paste selection locally when editing files on remote headless server

When connected to a remote headless Linux server via SSH, I want to be able to do 3 things: select text using the mouse and copy the selection into my local X clipboard paste from local X clipboard ...
J-S's user avatar
  • 33
1 vote
0 answers
30 views

Problem copying form vim to system clipboard [duplicate]

I usually do this with "*y (from visual mode), but on the linux box I'm working with (lubuntu) when I press * after " in visual mode, vim doesn't insert * (it just ignores the whole "*). If I check * ...
Jorge Lopez's user avatar
10 votes
2 answers
3k views

Difference between "* and "+ registers in +clipboard VIM?

"*p and "+p seem to behave the same. I tried :help "*, but it's talking about mouse selection, and :help "+ tells me There are three documented X selections: PRIMARY (which is expected to ...
minseong's user avatar
  • 2,363
4 votes
1 answer
3k views

How to copy long line from terminal buffer as it is without adding new lines?

I wanted to copy a public key from one machine to the other. I opened up vim and had two terminal buffers - one for each machine. In the terminal in which I had the first machine I went into normal ...
ivan's user avatar
  • 263

15 30 50 per page