Linked Questions

24 votes
1 answer
33k views

How do I use the system clipboard with Vim in Arch Linux? [duplicate]

I am using Vim on Arch Linux through urxvt. Since there is no "Ctrl-V" or "Ctrl-Shift-V" support in urxvt, there is no way for me to paste things I have copied from my browser (let's say) into my vim ...
alexytsu's user avatar
  • 846
10 votes
1 answer
21k views

how to yank from vim to system clipboard? [duplicate]

I'm using the latest version of vim 8.2.148 on the latest version of arch linux 5.5.6-arch1-1 with the latest version of Openbox window manager version 3.6.1. I have written a document in vim and ...
Kes's user avatar
  • 663
0 votes
1 answer
14k views

How to paste from an external source on VI/VIM [duplicate]

I'm using VI right now to create a php file in AWS. I wanted to know if there was any way I could paste (as in copy/paste) an array from another file into my VI on PuTTY. The program is supposed to ...
ybordag's user avatar
3 votes
1 answer
5k views

Can't yank into * or + registers [duplicate]

I'm trying to yank to the system clipboard on Ubuntu 14.04. I can't yank into the + or * registers, though. Every time I visually select my text and type "*y or "+y the indicator on the bottom right ...
fuzzybear3965's user avatar
0 votes
1 answer
2k views

How to copy text to clipboard in visual mode? [duplicate]

I ran the following sequence of commands: V10j ⌘ c but it seems like this doesn't copy the ten lines to my clipboard. So how can I do this?
NeoZoom.lua's user avatar
  • 1,500
3 votes
2 answers
2k views

vimscript: how to get selected text in a register in normal mode? [duplicate]

I am trying to get the mouse selected text in a register in normal mode. If the selection is a substring, only the selection should be copied, not the complete word. Currently the script has: normal!...
Arun Prakash Jana's user avatar
1 vote
1 answer
610 views

How to merge OS'es clipboard with Vim's one? [duplicate]

How can I merge OS clipboard and Vim's one? I want them to be the same, so that I don't have to use "*y or "*p or "*d, instead just y, or p or d. How can I do that?
Torito's user avatar
  • 119
1 vote
0 answers
986 views

How can I reliably copy and paste between vim and other programs? [duplicate]

I have a hard time just copying and pasting between vim and other programs (firefox, chrome, gnumeric) as well as other instances of vim. Normally I try to copy/yank with "+y and paste with "+p. ...
user avatar
0 votes
0 answers
504 views

System clipboard not working via ssh [duplicate]

I work on a remote server and would like to yank stuff to the server's clipboard. However "+y gives me an error flash (visual terminal bell) and when quitting vim, I can't paste in the terminal. ...
oarfish's user avatar
  • 1,277
-1 votes
1 answer
297 views

How to always paste to clipboard? [duplicate]

I am searching for an option to always paste to the system clipboard when using any kind of yank action, because I want to use Vim as the scrollback buffer for Kitty. I have already tried clipboard=...
neolith's user avatar
  • 133
2 votes
0 answers
278 views

Ctrl+Ins keybinding won't work in Vim, does in gVim? [duplicate]

I have the following in my .vimrc (I don't recall where I found the original): " Cut, Copy, Paste vnoremap <S-Del> "+x vnoremap <C-Insert> "+y If I use Shift+Cursor keys to ...
Roger Lipscombe's user avatar
0 votes
1 answer
228 views

Vim yank and paste via a shared file [duplicate]

I posted this question on StackOverflow first, as I did not know about "Vi and Vim beta". How to augment Vim yank and paste, so when I yank, Vim writes the content to a file? When I paste, it uses ...
ashim's user avatar
  • 101
1 vote
1 answer
117 views

Why cant i use `"+` in vim? [duplicate]

Previously, whenever I typed "+yy in vim, it yanked a line to the system clipboard. I reinstalled the OS again, and, when I try to do the same now the input disappears after entering +. Steps: I ...
Machine Yadav's user avatar
1 vote
0 answers
61 views

How to find out the default system copy register? [duplicate]

I want to know how to find the default copy register on any machine. I ssh into different machines and use vi. But on some of them the "+ and/or "* registers don't work. Also when I can use my mouse I ...
ivan's user avatar
  • 263
1 vote
0 answers
56 views

No + or * register on Linux (accessed via SSH from macOS)? [duplicate]

I am on Ubuntu 14.04.3 and Vim 8.2. I'm trying to figure out how to access either the * or + clipboard on Ubuntu but it seems like it doesn't exist? After doing "*yy and "+yy on lines of ...
David542's user avatar
  • 2,455

15 30 50 per page