Linked Questions

-2 votes
1 answer
3k views

Why vim highlight some specific words? [duplicate]

Why my vim highlight some specific words? As showing in the following screenshot picture. How can I locate my problem? There is my .vimrc file. set nocompatible " be iMproved, required filetype ...
1 vote
1 answer
264 views

Some "local to window" settings are being reset in Vim [duplicate]

I added :set numberwidth=2 in my vimrc, but this value is always returned to 4 inside my windows. It seems I need to use some autocommand to always force this value back to 2. In fact, even more ...
  • 2,091
0 votes
0 answers
284 views

Vim still create backup/swap/undo folder under .cache when set nobackup/noswapfile/noundofile [duplicate]

I got a strange behavior of vim 8.1 1-279 / archlinux 4.17.14 This is vim under console but I believe there's no different. Vim force create ~/.cache/vim/{backup,swap,undo} folders even I set ...
  • 1,136
2 votes
0 answers
115 views

Vim: error opening files <SNR>62_InitializePythonBuiltin the Python's site module could not be loaded [duplicate]

I have set up vim on a new machine according to Vimlander-2-The-Quickening, but I keep running into the following errors when I open a file in command mode: :e /path/to/file, :vs /path/to/file, or :sp ...
  • 151
0 votes
0 answers
65 views

My cursor is changed after "df" [duplicate]

I have the following to change my cursor from a block into an underline: set guicursor=a:hor20-Cursor Whenever I run df to delete a range, my cursor is changed back to a block. I have to source my ...
2 votes
0 answers
59 views

Vim has started adding commas unnecessary places [duplicate]

When I use :w to save my JSON file, vim automatically adds some commas at syntactically significant (?) places.  It does not happen when I use :x or ZZ.  This started today.  I did not change anything ...
  • 21
0 votes
0 answers
25 views

How to automatically start in Normal mode? [duplicate]

I am using zsh on Mac and noticed that whenever I start vim, it always starts in insert mode. I use vim to inspect files more often than to edit. I tried adding set noinsertmode but it didn't have any ...
  • 101
0 votes
0 answers
16 views

How to diagnose configuration---:w doesn't always work [duplicate]

I've somehow introduced a problem in my Vim configuration and I don't know how to track down where the problem is. Sometimes (most times) when I do :w then the buffer is not actually written; ...
  • 113
49 votes
4 answers
18k views

How can I get Vim to ignore all user configuration, as if it were freshly installed?

In order to ensure that behaviour is not affected by my personal config, I want to start Vim in a way that ignores all my user-installed config files, as if Vim had just been freshly installed for the ...
  • 28.9k
21 votes
3 answers
14k views

No syntax highlighting in tmux

I installed tmux in iTerm 2.(Build 3.0.13) When I execute vim in tmux, syntax highlighting looks like this. But outside tmux, syntax highlighting looks fine. My $TERM inside and outside tmux is ...
  • 465
13 votes
3 answers
6k views

Vim slows down over time with syntax on

Is there anything I can do to keep syntax on when using Vim? As soon as I open anything substantial it becomes nearly impossible to edit after a while. Every keypress causes a delay. If I turn syntax ...
  • 2,252
10 votes
1 answer
7k views

Most annoying slow-down of a plain-text editor! [closed]

I am a happy user of VIM, except for some bits which I really want vim to improve on. One main issue is frequent slowdown of VIM spoiling the amazingly productive text-editing experience on a fastest ...
2 votes
2 answers
9k views

How do I restore visual mode selection highlighting?

Somehow, over the last few days, the visual mode in Vim no longer flips the background highlight, as it used to. Now, if the file is recognized by something it can syntax highlight, it seems to ...
9 votes
3 answers
1k views

Automatically close oldest buffers?

I needed to edit a lot of files recently for a small change in each file. To get to each file, I browsed through NERDtree and opened one file after another. As I opened more and more files, I ...
2 votes
2 answers
11k views

Access a file under subdirectories of a path through gf command

I am using perl. When I press gf while having the cursor on Testcase, it shows E447: Can't find file "Testcase.pm" in path. So I added that path. It works for files under particular path which ...
  • 3,102

15 30 50 per page
1
2 3 4 5
17