0

I installed vim 8.0 for Windows last week. It seemed to work great the first few days, but now I have found that when I open a file in vim console mode, the editing window comes up without a menu bar (i.e. the bar at the top that has entries named File Edit Tools etc.). I've been using vim for over 20 years and have never seen this before. I think that I may have accidentally changed an option setting but I haven't been able to figure out what it is. Is there an option to get the menu bar to display? I've tried lots of things, like setting guioptions, but nothing helps. Thank you.

  • 4
    "console mode" ? Search for GVim.exe, make a desktop shortcut, and start that instead :) – VanLaser Oct 19 '16 at 20:39
5

I think you are confused about terminology. "Console vim" has never had a menu bar. Here is a snapshot of windows' console vim with all the default settings:

enter image description here

(Pretty ugly IMO)

No menu bar. This is because it is running inside of windows' cmd program, which does not have support for GUI features such as menu bars; it's purely text based. You have probably been using Gvim before. For reference, here is what Gvim looks like on windows with all default settings:

enter image description here

This does have a menu, and it can be configured with guioptions. I would recommend following VanLaser's advice, and sticking with gvim. In my experience it runs a lot better on windows than the console version, as well as having the menu bar you're looking for. If you installed vim in the default location, you can find gvim at

C:\Program Files (x86)\Vim\vim80\gvim.exe

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.