0

I know they have many topics about that, but i no one of them works.

My configuration worked before to switch between split window, but my session has been re-init and i lost my osx config and it's not working anymore.

In my .vimrc i have:

nnoremap <silent> <ESC>^[A <Nop>
nnoremap <silent> <ESC>^[B <Nop>
nnoremap <silent> <ESC>^[D <Nop>
nnoremap <silent> <ESC>^[C <Nop>

nnoremap <silent> <C-Right> <c-w>l
nnoremap <silent> <C-Left> <c-w>h
nnoremap <silent> <C-Up> <c-w>k
nnoremap <silent> <C-Down> <c-w>j

On iTerm i set my terminal as Terminal App default (i tried with xterm default too)

In the system preference, i disable the mission control keys with ctrl + arrow key in System preference.

with sed -n l i have

LEFT: ^[[D | CTRL + LEFT: ^[[5D

  • 3
    See the faq here and here – Christian Brabandt Oct 19 '16 at 12:13
  • So nnoremap <silent> <esc>[5D <c-w>h should work ! – dNitro Oct 19 '16 at 12:45
  • Awesome @ChristianBrabandt ! Thank you i didn't know the ctr+k ctrl+v tips !! i fix the ctrl left and right, but the problem is ^-k ^ <up> print me <Up> instead of <C-Up> any idea ? – albttx Oct 19 '16 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.