3

YouCompleteMe puts symbols in the "gutter" (left of the editor) for errors:

gutter present

The problem is that the gutter shifts the whole editor over, and it is only present when there is at least one error. Compare:

enter image description here

Short of always writing code with at least one error, how can I keep the width constant?

  • Or you could simply disable signs. – romainl Sep 12 '16 at 18:34
5

Install Vim 8 (released a few hours ago), and set signcolumn:

set signcolumn=yes

This is a actually available in Vim 7.4.2201 and later, but you really should go for the major release instead.

  • Wow... good thing I didn't ask this question a few hours earlier... – Owen Sep 12 '16 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.