6

I am using the cmder under windows 7.

I am using Vim version 7.4; I'm using the airline plugin and I installed the powerline font/patch.

I followed the instruction and also added the following to my vimrc:

if !exists('g:airline_symbols')
    let g:airline_symbols = {}
endif

" unicode symbols
let g:airline_left_sep = '»'
let g:airline_left_sep = '▶'
let g:airline_right_sep = '«'
let g:airline_right_sep = '◀'
let g:airline_symbols.linenr = '␊'
let g:airline_symbols.linenr = '␤'
let g:airline_symbols.linenr = '¶'
let g:airline_symbols.branch = '⎇'
let g:airline_symbols.paste = 'ρ'
let g:airline_symbols.paste = 'Þ'
let g:airline_symbols.paste = '∥'
let g:airline_symbols.whitespace = 'Ξ'

" airline symbols
let g:airline_left_sep = ''
let g:airline_left_alt_sep = ''
let g:airline_right_sep = ''
let g:airline_right_alt_sep = ''
let g:airline_symbols.branch = ''
let g:airline_symbols.readonly = ''
let g:airline_symbols.linenr = ''

But still the status bar shows funny characters. Does the airline for Vim even work on windows (NOT using the cygwin) just using the cmder?

Thanks

3

From issue#225 of cmder:

This not a specific problem of cmder, but rather of cmd in general, which does not use UTF-8 by default.

So just run chcp 65001 from cmder terminal to set unicode code page to UTF8.

BUT this way you should run this code every time you are going to use cmder; To automate this:

You can just add a "@chcp 65001 >nul" at the bottom of the vendor/init.bat.

This way unicode will set on cmder initiation.

0

In cmder setting page Startup -> Environment, add the following setting:

set LANG=en_US.utf8
chcp utf-8

It shout solve your problem. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.