2

Is there any way to trace the source of an auto-complete event within (Mac)Vim? Ie, where within which plugin this is and how it can be turned off?

In my case, I type {} in a .tex file and it automatically converts it to {}<++>, necessitating an Esc u to return to the original {}. I just want to be able to type {} and for the auto-complete event not to occur.

Note, although I have this specific problem, I am looking for general information about tracing the origin of such problems.

Thank you.

  • 3
    This is not autocompletion. You have installed a tex package that comes with abbreviations. See :help abbreviations. Use :verbose abbrev {} to see where it is defined. – romainl Aug 23 '16 at 6:14
  • @romainl You should post that as an answer. – DJMcMayhem Aug 23 '16 at 6:21
  • Hmmm, this doesn't look like an abbreviation. :verbose imap {} will probably put you on the right track but that plugin seems overly complex to me. Not sure how to disable that specific mapping. You should use it's issue tracker. – romainl Aug 23 '16 at 8:12
1

This is due either to an imap or an iabbrev. You can do either of these to check if there are any current definitions:

:[verbose ]imap {}
:[verbose ]iabbrev {}

Here, verbose is optional and will tell you where things are defined.


The particular mapping in your question is defined by vim-latex, and as suggested by @romainl in a comment to your question, it is an imap. However, the same "problem" could also come from an abbreviation, which is defined with the :iabbrev.

For relevant help sections, see:

  • :h :imap
  • :h :iabbrev
  • :h :verbose
  • :h latex-macros

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.