0

I want to be able to write German texts using my Vim 7.4 installed on a Windows 10 machine with Russian locale and German keyboard layout.

My .vimrc file looks like this:

set encoding=utf-8
set fileencoding=utf-8

I can't neither enter German Umlauts, nor display those entered in another editor (i. e. ä is displayed like a etc.).

Russian text can be both entered and is displayed correctly.

How can I make sure that I can write in German, English and Russian in the Vim editor (in the same file) ?

5
  • What is the output of :set termencoding?
    – SibiCoder
    Jul 22, 2016 at 7:13
  • termencoding=cp866 Jul 22, 2016 at 7:27
  • I guess you can change it to :set term encoding=utf8
    – SibiCoder
    Jul 22, 2016 at 7:43
  • What line do I need to add to .vimrc in order for term encoding to always be UTF-8? Jul 22, 2016 at 8:07
  • :set termencoding=utf8 in vimrc
    – SibiCoder
    Jul 22, 2016 at 16:06

1 Answer 1

1

After I reinstalled the program with "Native language support" disabled (in the installer), the problem disappeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.