4

I was trying out nvim (neovim) for the first time and I find that I have to type <escape> twice to get out of insert mode.

I'm not sure if this is a feature or a bug. I see the same behaviour on both Mac and Linux (i.e. escape, followed by a move command such as 'k', inserts a k in my buffer).

Is there a way to configure this editor to use a single escape instead of two to get to NORMAL mode?

EDIT: I'm not using tmux (at least not explicitly). I'd tried the tmux method of changing the timeout, but it produced a syntax error, so I wasn't sure that was the issue. However, the issue I am seeing does appear to be timeout related nonetheless. If I wait (an unnaturally long time compared to what I am used to), the editor does switch back to normal mode.

EDIT2.1: The software I am using is: Mac terminal + ssh + screen + nvim. Initially it seemed like adding a .tmux.conf file (on my mac) with 'set -s escape-time 0' in it fixes this issue (on the mac), but I still see escape delays with terminal+ssh+screen+nvim and cause me to mess up my editing session after hitting escape and not waiting long enough.

  • 1
    Are you in tmux? (As the linked bug suggests) – FDinoff Jul 17 '16 at 16:35
  • Why don't you map two escapes to a single escape :D – SibiCoder Jul 17 '16 at 16:37
  • 1
    What FDinoff said. I just tested this and it does happen under tmux: neovim (and vim too) has a delay when pressing the <esc> key. 2 presses are not required, it is just a delay. – grochmal Jul 17 '16 at 16:40
  • Also, see this U&L question. Maybe the delay is caused by that (it was for me). – grochmal Jul 17 '16 at 16:45
  • 1
    :imap without arguments produces no results. – Peeter Joot Jul 17 '16 at 17:20
-2

I was having the exactly same problem Mac terminal + ssh + screen + nvim, solved by setting empty guicursor

set guicursor=

Problem and solution are explained here: https://github.com/neovim/neovim/issues/6403

  • This doesn't really look like the same issue. Also, the solution is in no way general, instead, it is a solution that works to solve the issue at neovim#6403 for neovim run in specific terminal emulators (i.e. konsole in this case). – Karl Yngve Lervåg Jul 5 '17 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.