3

I have a Vi running as BusyBox executable (VMware ESXi):

$ vi --version
BusyBox v1.20.2 (2014-08-27 12:48:18 PDT) multi-call binary.

Is there a way to disable auto-indent when pasting the code? Neither of the methods described in Turning off auto indent when pasting text into vim works for Busybox.

I can set noautoindent before pasting and set autoindent after, but is there a persistent method?

  • You can use autocommands/mappings to set and unset based on your keys/clicks. Did you tried :set paste command before pasting ? – SibiCoder Jul 17 '16 at 8:16
  • 3
    @SibiCoder, the question is about "BusyBox Vi", not "Vim". – romainl Jul 17 '16 at 8:17
5

Judging by the source, the only settable options in "BusyBox Vi" are:

autoindent
showmatch
ignorecase

So, the answer seems to be "no".

0

Don't know about BusyBox, but avoiding indentations is effective with the :se paste command. I include in my ~/.vimrc the definition:

map #P :se paste

so by doing #P I can turn indenting off. Useful when copying and pasting from one terminal to another.

  • The 'paste' option doesn't exist. – Antony Jul 21 '16 at 7:05
  • @Antony It does in normal vim. Try :set all and all possible options are shown. – Víctor Luaña Jul 21 '16 at 9:09
  • The OP isn't using vim. – Antony Jul 21 '16 at 10:12
  • @Antony Thanks, I realize now. Didn't know about BusyBox. – Víctor Luaña Jul 21 '16 at 19:08
  • Aye, there are several variants of vi around, though Vim is the most popular. – Antony Jul 21 '16 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.