0

I use Vim 7.4.521 under Kubuntu 14.04.4. I downloaded and installed Nvim-R 0.9.5 (for Vim >= 7.4.1829) via :so %. Doing the following:

$ vim somefile.R

on a file containing R code results in Vim reporting:

Nvim-R requires ... Vim >= 7.4.1829

If using Vim, it must have been compiled with both +channel and +job features.

Running this:

$ vim --version | grep "channel\|job"

returns nothing.

Do I need to download2 a newer or different version of Vim? I'd like to avoid compiling Vim from scratch ;)

1: As reported on the splash screen when starting Vim. apt-get reports version "7.4.052".

2: vim.org is down at the moment.

5
  • 1
    Nvim-R uses jobs. Get the latest development version of Vim (currently 7.4.2031), compile and install it. Or install Neovim instead. Also, use a real package manager, don't install plugins from vimballs. You don't even want to know what those are in 2016. Jul 13 '16 at 14:44
  • I should apt-get remove all existing versions of Vim before installing via git?
    – SabreWolfy
    Jul 14 '16 at 7:45
  • 1
    You should try Neovim first, it has a more mature support for jobs. No idea if they have binaries for your system (or if they make available binaries at all). If you plan to compile Vim then yes, you should remove the existing one first. But beware that you'll have to maintain it manually from that moment on. Also beware that you'll have to know what you're doing to make it work. Wait for official support for newer Vim in your distribution if you aren't comfortable with that. Or ask your sysadmin to do it for you. Jul 14 '16 at 7:54
  • 1
    I am facing this problem too, but it seems awkward because my vim version is "7.4.488", and it says " Nvim-R requires either Neovim >= 0.1.4 or Vim >= 7.4.1829". And what does this "If using Vim, it must have been compiled with both +channel and +job features" mean? and how can I do it? I have compiled Nvim-R.vmb via :so % Jul 15 '16 at 14:48
  • You can check the options Vim was compiled with by doing vim --version. 488 < 1829, so your version is too old. Compiling Nvim-R is different to compiling Vim.
    – SabreWolfy
    Jul 15 '16 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.