5

Couldn't find anything on this by searching, so hopefully it's not super obvious. Every now and then, through some accidental sequence of keys, a solid bar appears to the left of my line numbers.

I have no idea how to get rid of it. Note that this is not a result of me searching the empty string, as 'response' is the highlighted string match. It is local to the particular file, so it doesn't show up when I open other documents.

Any insight would be much appreciated.

Vertical Bar

6

I have a couple guesses.

My first guess is that this is because you have "diff" on, most likely because you had done "diffthis" at some point, or started vim in diff mode. From :help diffthis

                            *:difft* *:diffthis*
:difft[his] Make the current window part of the diff windows.  This sets
        the options like for "vimdiff".

You can turn this mode off with :diffoff, or if you prefer the shorter version :diffo.

If it's not that, it might also be "foldcolumn". Does :set foldcolumn=0 fix it?

  • 1
    diff was the answer. Thanks. Out of curiosity, and to help future troubleshooting, what was the critical clue there? – Tyler Holden Jul 6 '16 at 21:36
  • 1
    @TylerHolden The critical clue was your picture. I've used :diffthis a fair bit before, and so I recognized the column on the left. – DJMcMayhem Jul 6 '16 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.