1

Say I have one window open displaying folder foo. Then I open a new window by doing :vs ~/bar. Then I get a Nerdtree, and when using Ctrlp's fuzzyfinder by doing ,,. I expect the files displayed to be the path of folder bar, but instead I get files for folder foo.

How can I make Ctrlp display the files for the right folder? Is there any other command than :vs I should be using?

One solution that works is opening a file in the bar folder. But I don't really want to fill up my buffer list with files I'm not using.

I'm using dotvim.

  • Tried :set autochdir ? – SibiCoder Jun 26 '16 at 11:54
  • @SibiCoder: That seems to show all files from my home folder, not the bar folder – dan-klasson Jun 26 '16 at 13:45
  • You might try setting path to include files from certain path permanently. Do you want only the current folder temporarily? – SibiCoder Jun 26 '16 at 14:16
  • @SibiCoder: No, I want it like that always and not for specific folders. Sometimes I want to see code from different repos in two windows next to each other. – dan-klasson Jun 26 '16 at 14:33
  • Read this github.com/kien/ctrlp.vim/issues/150 – SibiCoder Jun 26 '16 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.